Jailbreak attempt: iPod Touch 3G won't upgrade to 3.1.3!!

Discussion in 'iPod touch' started by DeusEx, Jun 27, 2010.

  1. DeusEx

    DeusEx New Member

    Joined:
    Jun 26, 2010
    Messages:
    26
    Likes Received:
    0
    Hi,

    I have a brand-new 32GB iPod Touch 3rd Gen, and have been trying to jailbreak it with Spirit - however it came with 3.1.1 firmware, and Spirit only works with 3.1.2/3.1.3. I tried downloading both 3.1.2 and 3.1.3 firmwares, and manually installing them with the hold-shift update in iTunes, as well as straight-up trying to restore it, but each time:

    "this device isn't eligible for the requested build" message comes up.

    I'm at a loss what to do - looking for some assistance, thanks. P.S. Tried both iTunes v9.1.0/9.1.1.
  2. EviLCorsaiR

    EviLCorsaiR New Member

    Joined:
    Jul 2, 2009
    Messages:
    43
    Likes Received:
    0
    Device:
    iPad
    Sadly, I think you're pretty much stuffed. Apple aren't signing 3.1.2 or 3.1.3 anymore by the looks of things so it's impossible to upgrade/downgrade to them. The only option is an upgrade to 4.0.

    It IS possible to restore to 3.1.2/3.1.3 but for that you would have had to have SHSH blobs saved, and for that, you would have already had to be on one of the firmwares.

    So, sadly, you can't.
  3. masterx02

    masterx02 New Member

    Joined:
    Jan 28, 2009
    Messages:
    37
    Likes Received:
    0
    Yea, just wait for 4.0 jailbreak which shouldnt be too long from now maybe a week or 2
  4. m0in

    m0in Well-Known Member

    Joined:
    Dec 28, 2009
    Messages:
    2,723
    Likes Received:
    28
    Device:
    4G iPod touch
    If you can deal with a tethered JB, Blackra1n is a great option.
  5. DeusEx

    DeusEx New Member

    Joined:
    Jun 26, 2010
    Messages:
    26
    Likes Received:
    0
    ^Is Blackra1n upgradeable to say, the next version of 4.0-enabled Spirit?
  6. ibizaGTi

    ibizaGTi New Member

    Joined:
    Dec 19, 2009
    Messages:
    638
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    No. Blackra1n will jailbreak 3.1.1 for you, but will be tethered.
    If you later want to JB with Spirit, you will have to restore.
  7. NiKox187x

    NiKox187x New Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    0
    Device:
    3G iPod touch
    I had the same problem, you need to update iTunes. With now Spirit compatibility.
  8. TerraPhantm

    TerraPhantm Member

    Joined:
    Jul 15, 2008
    Messages:
    152
    Likes Received:
    1
    Device:
    iPhone 4S (Black)
    Spirit is modifiable for other firmwares that have the vulnerability, but you need the source code. Try messaging comex, maybe he'll be nice and give you a one-off build.
  9. NiKox187x

    NiKox187x New Member

    Joined:
    Apr 27, 2010
    Messages:
    11
    Likes Received:
    0
    Device:
    3G iPod touch
    Update to iTunes 9.2..download the iPT2G 3.1.2 firmware, then Shift + Update and point it at the firmware you downloaded. You should be updating to 3.1.2. Then with the new iTunes, Spirit is now compatible.

Share This Page