Jailbreak and Unlock New 3g?

Discussion in 'iPhone' started by martd, May 12, 2009.

Thread Status:
Not open for further replies.
  1. martd

    martd New Member

    Joined:
    Oct 24, 2008
    Messages:
    17
    Likes Received:
    0
    Hi all

    I have just received a new iPhone 3g.

    Obviously I want to jailbreak it but i'm locked into a VF contract so need to unlock it.

    The phone has FW 2.1.1 and BB 02.30.03

    Now, I understand that if I have the newer boot loader I wont be able to step back to the correct BB for unlocking.

    So, my question is this:
    How should I jailbreak my iPhone so that I can look into the possibility of a BB step back?

    Should I use QuickPwn 225-2 with 2.2.1 FW and try it or with 2.2 FW?

    Any advice would be MOST welcome.

    (Ive tried searching but i'm not finding answers to this specifically - bit of a newbie i'm afraid)

    Cheers

    MD
  2. mattym

    mattym New Member

    Joined:
    Sep 22, 2007
    Messages:
    786
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    I think almost every article in this whole section has at least one post in it that would have given you your answer. IT CANT BE DONE. We dont currently have the means to do this via software. Baseband's and Bootloaders cannont be changed via software at this time.
  3. martd

    martd New Member

    Joined:
    Oct 24, 2008
    Messages:
    17
    Likes Received:
    0
    Indeed, but I beg to differ.

    IT CAN BE DONE - IF the iPhone has a bootloader of 5.8 then it is downgradable using pHasBanDowngrader.

    Generally any iPhone made before September 08 has 5.8 but after are likely to have 5.9.

    I'm after a way to find out on my phone.

    I know how to find out but it needs to be jailbroken first - hence the question in my first post
  4. RoYaLx

    RoYaLx Member

    Joined:
    Mar 11, 2009
    Messages:
    939
    Likes Received:
    22
    Device:
    HTC One
    Even if you downgrade the firmware, the baseband will remain at 2.30.03. Sorry, there are NO current ways of unlocking it via software, but I believe there are SIM cards that will unlock it.
  5. martd

    martd New Member

    Joined:
    Oct 24, 2008
    Messages:
    17
    Likes Received:
    0
    hmmm, Sorry but I dont think you're right.

    pHasBanDowngrader downgrades the Modem FW to 02.28.00
    That IS the BaseBand, not the iPhone FW (which would be 2.2.1)

    In fact theres even an app in Cydia that will do it too.

    BUT - only if its bootloader 5.8
  6. mattym

    mattym New Member

    Joined:
    Sep 22, 2007
    Messages:
    786
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    yes like my first post said it cant be done. Dont correct me by trying to change information. the fact is you dont have a 5.8 phone and thats what our answers were based on. Which like i said could have easily been found by searching in any of 90% of the posts on this page.
  7. martd

    martd New Member

    Joined:
    Oct 24, 2008
    Messages:
    17
    Likes Received:
    0
    Hang on, I didnt change information.

    All I did was ask the best way to JB my phone to check the bootloader.

    You didnt mention anything about my phone not having 5.8. You just said that BB cannot be changed via software which is factually incorrect.

    If i'd had bootloader 5.8 then the BB could be altered. Fact!

    Look, I dont want to get into an arguement about this mate, I just wanted some info.

    If you're 100% sure that my iphone wont have BL 5.8 then i'll end my quest here.
    But my iPhone may well have had BL 5.8. Without checking theres no way of knowing for sure.
    (I'm pretty sure it doesn't to be honest! Due to the S/N)

    Thanks for your input though guys
  8. leadergo

    leadergo Active Member

    Joined:
    Aug 2, 2008
    Messages:
    2,384
    Likes Received:
    6
    how do you know what bootloader you have?
  9. martd

    martd New Member

    Joined:
    Oct 24, 2008
    Messages:
    17
    Likes Received:
    0
    I dont mate but mattym is 100% sure it doesnt have 5.8 due to his insistence that I cant do it

    Please Register or Log in to view images

  10. Soutar_3DG

    Soutar_3DG Member

    Joined:
    Mar 29, 2009
    Messages:
    296
    Likes Received:
    0
    Device:
    2G iPod touch
    one of the baseband downgraders tell you what BL you have cant remember what one
Thread Status:
Not open for further replies.

Share This Page