Jailbreak 2.2.1 iTunes 8.2, which tool?

Discussion in 'iPod touch 2G Jailbreak: redsn0w, 24kpwn, etc.' started by CurveBall, Jul 19, 2009.

  1. CurveBall

    CurveBall New Member

    Joined:
    Mar 7, 2009
    Messages:
    46
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    So, I'm going to buy an iPhone 3G next week, and that device is probably still on 2.2.1. I want to jailbreak it and leave it on 2.2.1 because I'm not pretty happy with 3.0. 3.1 might be better but I'll stay with 2.2.1 until then.

    So, the question is: I have iTunes 8.2 and I want to jailbreak it with firmware 2.2.1 on it. What tool should I use? redsn0w 0.7/0.8? Can it jailbreak 2.2.1? Or do I have to downgrade iTunes to 8.1 and jailbreak with QuickPwn 2.2.5-2 and after that update my iTunes again?
  2. alfredomeres

    alfredomeres New Member

    Joined:
    Feb 1, 2009
    Messages:
    8
    Likes Received:
    0
    Device:
    2G iPod touch
    redsn0w 0.3, and you can stay in iTunes 8.2
  3. CurveBall

    CurveBall New Member

    Joined:
    Mar 7, 2009
    Messages:
    46
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    iTunes 8.2 updated AplleMobileService drivers. I dont think redsn0w 0.3 can handle those...
  4. pwnthe2G

    pwnthe2G Member

    Joined:
    Mar 7, 2009
    Messages:
    683
    Likes Received:
    5
    Device:
    4G iPod touch
    redsnow 0.8.... jailbreaks all devices and im pretty sure 2.2.1 if not then downgrade itunes to like 8.0 lol or whichever one was before the updated drivers and use redsnow 0.3
  5. ..'Ant'..

    ..'Ant'.. New Member

    Joined:
    Apr 16, 2009
    Messages:
    97
    Likes Received:
    0
    Device:
    3G iPod touch
    Redsn0w 0.3 jailbreaks fine with Itunes 8.2 here.
  6. CurveBall

    CurveBall New Member

    Joined:
    Mar 7, 2009
    Messages:
    46
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    You tested it? That was something I wanted to hear. thx
  7. CurveBall

    CurveBall New Member

    Joined:
    Mar 7, 2009
    Messages:
    46
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    redsn0w 0.3 isn't compatible with iPhone 3G...
  8. pryvisee

    pryvisee Member

    Joined:
    Dec 26, 2008
    Messages:
    73
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    i used unoficial sn0w
  9. LeSnak

    LeSnak New Member

    Joined:
    Jul 7, 2009
    Messages:
    185
    Likes Received:
    0
    Device:
    3G iPod touch
    can you use QuickPwn with iTunes 8.2?I need to know
    Sorry 2 interrupt

    Please Register or Log in to view images

Share This Page