Itunes version needed?

Discussion in 'iPod touch Firmware 3.0 Jailbreak' started by Nugget246820, Jun 17, 2009.

  1. Nugget246820

    Nugget246820 New Member

    Joined:
    Jan 26, 2008
    Messages:
    42
    Likes Received:
    0
    I've been reading around about the 3.0 jailbreak and a couple of places have said I need a version lower than 8.2 itunes
    Can anyone tell me if i do or not?
    Thanks
  2. SiN Altr Ego EL

    SiN Altr Ego EL New Member

    Joined:
    Feb 10, 2008
    Messages:
    905
    Likes Received:
    1
    Device:
    iPad w/ 3G
    yes. u do need itunes 8.2.

Share This Page