iTunes refusing to display album as one album, uses two instead

Discussion in 'iTunes' started by multimolti, Nov 5, 2009.

  1. multimolti

    multimolti New Member

    Joined:
    Oct 18, 2009
    Messages:
    37
    Likes Received:
    0
    Device:
    3G iPod touch
    Hi!

    This is really a minor issue, but still somehow annoying. I have the soundtrack of the movie Transformers as MP3 files. All the files have "Soundtrack" as artist and genre, "Transformers" as album and their own titles/track numbers.
    But iTunes still displays it in two different albums.

    I tried removing them from the library and adding again, manually set the tags again with Mp3tag, manually did it inside iTunes, ... but nothing will help!

    Screenshot attached. Can anyone help?

    Attached Files:

  2. alexb78

    alexb78 New Member

    Joined:
    Jun 16, 2008
    Messages:
    3
    Likes Received:
    0
    Device:
    2G iPod touch
    Is there something in your song information like "sort album" in "sorting" tab? --alex
  3. zDSpider

    zDSpider Member

    Joined:
    Jul 5, 2009
    Messages:
    705
    Likes Received:
    8
    Device:
    2G iPod touch
    Post another screenshot but this time with the "Get Info" windows for track 5 and any other track from the other album (ie. track 1).

    You could also select all the tracks in iTunes (ctrl+click or shift+click) and choose Get Info. Most likely the field that doesn't match will be blank. Or they could all be blank.


    Possible issues:

    - One of the entries in track 5 has a space somewhere (even at the end) or a different letter or something ("Trasnformers" instead of Transformers) and doesn't match up with the rest of the album.

    - The album cover is different for track 5 (same res, same bytes but different crc/md5).

    - Track 5 is a broken file that cannot retain tags or cannot retain them properly. You should either transcode it at a higher bitrate (so as not to lose quality) or simply leave it out.


    PS: I usually set "Various Artists" for the Artist section.
  4. multimolti

    multimolti New Member

    Joined:
    Oct 18, 2009
    Messages:
    37
    Likes Received:
    0
    Device:
    3G iPod touch
    There really is no spelling mistake or space in any of the files, my program Mp3tag wrote the same tags again and again into the files. I also removed the cover of each file and added it to all of them at once again, and here are the screenshots you requested.

    Didn't help at all.

    Attached Files:

  5. zDSpider

    zDSpider Member

    Joined:
    Jul 5, 2009
    Messages:
    705
    Likes Received:
    8
    Device:
    2G iPod touch
    Try setting Artist and Album Artist to "Soundtrack" for all the files (select them with ctrl+click or shift+click in iTunes and choose Get Info).

    Oh, and as Alex suggested, make sure the Sorting tab is empty.
  6. Jam...

    Jam... New Member

    Joined:
    Mar 14, 2009
    Messages:
    92
    Likes Received:
    0
    Device:
    2G iPod touch
    I have this and i sort it by checking all the options in the edit info screen, even if they are blank jus check them it should sort it out... Does for me anyways.
  7. multimolti

    multimolti New Member

    Joined:
    Oct 18, 2009
    Messages:
    37
    Likes Received:
    0
    Device:
    3G iPod touch
    Thats what I did, doesn't help
  8. SiXAXiS

    SiXAXiS Banned

    Joined:
    Dec 19, 2007
    Messages:
    1,915
    Likes Received:
    5
    Device:
    iPhone 3GS (White)
    Check the "Part of a compilation" button
  9. lunchmeats101

    lunchmeats101 New Member

    Joined:
    Sep 15, 2009
    Messages:
    353
    Likes Received:
    0
    Device:
    4G iPod touch
    I have the same problem, There are only 10 songs, but it displays them as 3 duplicate albums. I even selected all of the songs in the album, and gave them all the EXACT same Artist, Album, etc.
  10. Rich246

    Rich246 Member

    Joined:
    Oct 15, 2008
    Messages:
    143
    Likes Received:
    4
    Device:
    iPad 2 (White)
    Try removing them from iTunes... and then add it back by dragging the actual folder into iTunes... That seems to work for me if this happens

Share This Page