iTunes Problem with one Album

Discussion in 'iTunes' started by Elahrairah, Feb 19, 2008.

  1. Elahrairah

    Elahrairah Member

    Joined:
    Dec 15, 2007
    Messages:
    148
    Likes Received:
    2
    Hello,

    I have one album on my HDD that I call "Random Tunes" It holds all of my one hits that I like from various artists. I have everything from old Mideval tunes to "one hit wonders".

    I place them in this folder, give them the artist name, but album is labeled Random Tunes. Should the time come I get a 2nd tune from that artist, I will rename both to a new album name, and remove them from Random Tunes. Only one tune/artist allowed.

    So when I add this folder to my iTunes library, of course each tune gets it's own spot, because the artist is differetn, making the list look very long.

    Long story short, I dont see "random tunes" on my ipod. But when I use TC to download my tunes to another computer, they are there....

    Any help would be appreciated. I just want one album in the flow to be there, that lists all these tunes.

    Thanks.
  2. arjayquizon

    arjayquizon New Member

    Joined:
    Dec 21, 2007
    Messages:
    72
    Likes Received:
    0
    I am sorry, but could you please rephrase what you said? Thank you.

    From what I understood, maybe your ID3 tags are not edited? Try editing them first, then try it again.
  3. GregMac1213

    GregMac1213 New Member

    Joined:
    Dec 22, 2007
    Messages:
    17
    Likes Received:
    0
    Device:
    3G iPod touch
    You need to indicate that your 'Random Tunes' album is a compilation.

    Select all of the appropriate songs in iTunes, right-click, choose Get Info, and check the box that says 'Part of Compilation'.

    Then make sure that compilations is turned on:

    in iTunes: Preferences > General

    on iPod Classic and 3G Nano: enable the Compilations menu item on either the main menu or music menu.

    If I understood your original post, you have all of your individual songs tagged as:

    Album: Random Tunes
    Artist: individual artist name
    Album Artist: Various Artists

    Then all of the above should work.

    Note, however, that the touch does not (yet) filter compilations. So none of this will affect browsing on the touch. Each artist will still appear in your artists list. But the album will show up correctly in coverflow.
  4. arjayquizon

    arjayquizon New Member

    Joined:
    Dec 21, 2007
    Messages:
    72
    Likes Received:
    0
    What? The iPod Touch can filter out compilations. Check the "more" option in the music player, then you will see the "compilations" option.
  5. GregMac1213

    GregMac1213 New Member

    Joined:
    Dec 22, 2007
    Messages:
    17
    Likes Received:
    0
    Device:
    3G iPod touch
    You can use that option to see compilations. But there's no way to remove artists who appear only on a compilation from the artists list like you can on the other iPods.
  6. GaryK

    GaryK New Member

    Joined:
    Dec 27, 2007
    Messages:
    28
    Likes Received:
    0
    Device:
    iPod touch
    "Various"

    In the Get Info dialog, Info tab, I set the album title for each song to be the same. In your case, "Random Tunes". I also set the artist to be "various". I put the actual artist name as part of the song title for my information. That's all the info I provide. I attach an interesting album cover to all sones for album flow.
  7. Elahrairah

    Elahrairah Member

    Joined:
    Dec 15, 2007
    Messages:
    148
    Likes Received:
    2
    Hmm...now I have one album in the cover flow on the ipod...but iTunes still keeps them separate (in the "Center View") so the list is still very long, with about 150 tunes in this album...any way to get them all to show in one album in iTunes? Like I said, now it looks OK on the ipod itself.

    Gary, good advice, but it would take me a long time to do that....is that the key to my problem?

    Thanks for the help...
  8. GaryK

    GaryK New Member

    Joined:
    Dec 27, 2007
    Messages:
    28
    Likes Received:
    0
    Device:
    iPod touch
    I believe so. The center View is "Artist". Use something like various to set all artists to the same value. In my case, only one artist "Various" appears in the list.

Share This Page