iTunes not restoring? Error 1611? Try this.

Discussion in 'iPod touch' started by Dementedsnake, Sep 29, 2009.

  1. Dementedsnake

    Dementedsnake New Member

    Sep 29, 2009
    Likes Received:
    2G iPod touch
    Hi. Okay, I know normally, a thread is started by someone who's asking a question, but after spending three days wondering why I couldn't get iTunes to restore ANY firmware, I feel this is something worth mentioning. Also, I noticed a lot of people asking for help on this who never got an answer, so I hope this helps.

    ----Scroll down to skip the story---------

    So, a few days ago I decided it was time to jailbreak my iPod. I spent a lot of time looking around and even tried (unsuccessfully) to jailbreak it on someone else's computer. Then I came across a post on this website that introduced me to redsn0w.

    Thank you.

    Anyway, I tried it, happy that I didn't need to install any new programs or drivers on this other person's PC (Windows Vista 32 bit, if anyone cares). But I did it. redsn0w worked right off the bat and I easily and quickly got my iPod freed from the binds of the Apple monarchy.

    But by that time it was late and I could only mess with it for a few hours. When I woke up the next morning, I found my iPod laying on my bed, battery almost completely dead. After I unlocked it, it immediately turned off and restarted. Then, Apple logo, and nothing else. It was stuck at the boot screen and refused to do anything but turn off or enter DFU mode. It absolutely REFUSED to do ANYTHING ELSE. Well, I spent a day working on it, and tried many times to get it to restore to factory defaults. It didn't work.

    Every time, iTunes would see the device, tell me to restore it, make a fuss about getting the latest file for the perfect iPod upgrade, and then refuse to work. Okay, well that's not fair; it worked, just not completely. iTunes would get to the point where it popped a little progress bar on my iPod's screen and then sit there until an error message showed up. This error, ladies and gentlemen, was error 16-11! *cue dramatic music*

    Well, I tried downloading every program imaginable for windows and linux, but nothing worked. redsn0w would re-jailbreak it, but not fix it. Voltage would make pretty colors, but delegate to iTunes, which didn't solve anything. Redj0hnny and iRecovery were all but useless. And Hackintosh and 1clickboot did absolutely nothing useful. (No offense, I mean useless/useful for this problem). I was beginning to think that my battery dieing had somehow screwed up my iPod. I was even more worried I might have to get it replaced. But then I noticed something. Redsn0w had no troubles writing to my device, and iTunes could communicate with it no problem. It just couldn't write to it. It hadn't occurred to me earlier because I hadn't used it in so long but...

    ---------Story's Over, Sort of----------

    Libusb was interfering with my iTunes drivers and preventing iTunes from restoring my iPod properly. As soon as I went into device manager and switched the right drivers back into place, iTunes restored my iPod in a matter of minutes. After which I re-jailbroke the thing and started typing this.

    So, if you've had problems with iTunes not restoring your device, and/or getting error messages when you try, then uninstall the libusb drivers and try again. This isn't a fix for everything, but I know of at least five people on here this will help.

    P.S. You know, redsn0w has absolutely no problems writing to the iPod Touch, if someone can just figure out how to get it to write .ispw files, then we can replace iTunes completely.
  2. Unregistered

    Unregistered Guest

    usb drivers interfering...

    can u please elaborate on this - I have the same situation and need to restore my iPod Touch

    Libusb was interfering with my iTunes drivers and preventing iTunes from restoring my iPod properly. As soon as I went into device manager and switched the right drivers back into place,

Share This Page