Itunes can't detect my Touch: Pairing Device not found?

Discussion in 'iPod touch' started by Pooley, Jan 23, 2008.

  1. Pooley

    Pooley New Member

    Joined:
    Jan 23, 2008
    Messages:
    2
    Likes Received:
    0
    Hey there,

    I recently bought a touch and set it up and synced it to my flat-mates power book as my powermac was in service, it worked a treat and I was very happy with it.

    I got my powermac back so i re-installed osx tiger 10.4 and ran all the latest updates. I installed the latest version of itunes and finally i restored my touch to it's factory settings on my flat-mates power book. All went ok.

    I then hooked it up to my mac and i got the message "i tunes could not detect ipod as the pairing device is missing"

    I tried a different usb port, restarted, checked for any outstanding updates and it still said the same thing.

    Can anybody offer advice, I am pulling my hair out here

    Please Register or Log in to view images

    (

    It's a fairly old mac (G4 powermac AGP graphics 512mb) although it has all the needed software installed so there is no reason that i can see as to why that could be a problem.

    Thanks in advance.
  2. Juwilz

    Juwilz New Member

    Joined:
    Nov 25, 2007
    Messages:
    365
    Likes Received:
    1
    do u have the latest iTunes? which is 7.6 at the moment, and have u tried restarting ur ipod then doing it? or trying to plug the usb drive into another usb port?
  3. eric_chaos

    eric_chaos Well-Known Member

    Joined:
    Nov 4, 2007
    Messages:
    3,746
    Likes Received:
    35
    Device:
    iPhone 4 (Black)
    I had that problem too. I just restarted iTunes and it worked.

Share This Page