Itunes cannot install 2.1 on my device. HELP!!!!

Discussion in 'iPhone' started by Ipoodtouch, Sep 19, 2008.

  1. Ipoodtouch

    Ipoodtouch New Member

    Joined:
    Feb 28, 2008
    Messages:
    10
    Likes Received:
    0
    Hi guys, I was hoping someone could help me out on this. I have been trying to update my iphone currently on version 2.0.2 to 2.1, and when I try to install it on itunes, it first extracts the software, then attempts to backup my iphone, but it fails, and says "Itunes could not sync ^0 To the Iphone because an unknown error occurred (-30). This also happens when I sync the device to itunes. The backup takes very long to even begin, and then the error message appears. Please give me suggestions on how to fix this problem. Thanks!
    BTW my iphone is not hacked or modded or unlocked. It is legit.
  2. Veritas06

    Veritas06 New Member

    Joined:
    Dec 23, 2007
    Messages:
    468
    Likes Received:
    0
    Device:
    2G iPod touch
    For the backups, right click your iPhone & click 'Reset Warnings.' Eject your phone & reconnect it. When you get the pop up from Apple asking about sending statistics, say no. Then see if the device will backup or upgrade. If not, you could try putting it in DFU Mode & updating it.
  3. bob12345333

    bob12345333 New Member

    Joined:
    Mar 1, 2008
    Messages:
    155
    Likes Received:
    0
    try restoring before you update... or just restart computer + iphone... itunes can be glitchy at times
  4. Rotard

    Rotard New Member

    Joined:
    Sep 20, 2008
    Messages:
    1
    Likes Received:
    0
    i have this error and none of the suggestions below helped - please help

Share This Page