iTunes 8 1.1.x Compatible?

Discussion in 'iTunes' started by BemmerKid, Sep 10, 2008.

  1. BemmerKid

    BemmerKid Member

    Joined:
    Feb 11, 2008
    Messages:
    289
    Likes Received:
    0
    Device:
    4G iPod touch
    I read that you need to buy 2.1 fw to use the 1st gen iPod touch with iTunes 8. Is this true? Or just a rumor/lie?
  2. Meikura

    Meikura Super Moderator Staff Member

    Joined:
    Jan 16, 2008
    Messages:
    6,081
    Likes Received:
    431
    Device:
    iPhone 4 (Black)
    I'll check in a bit, and get back to you.
  3. cainy

    cainy New Member

    Joined:
    Jan 12, 2008
    Messages:
    489
    Likes Received:
    0
    nope you dont, anything with 1.x.x will work with itunes 8, you do however have to pay 4 the 2.1 uipgrade if you havent already purchased the 2.0 upgrade
  4. BemmerKid

    BemmerKid Member

    Joined:
    Feb 11, 2008
    Messages:
    289
    Likes Received:
    0
    Device:
    4G iPod touch

Share This Page