iTunes 7.6

Discussion in 'iPod touch 1.1.x Jailbreak' started by DrIzzy, Jan 21, 2008.

  1. DrIzzy

    DrIzzy New Member

    Joined:
    Dec 23, 2007
    Messages:
    10
    Likes Received:
    0
    Itunes is asking to upgrade to version 7.6 (currently have 7.5). I also have an iPot 1.1.2 (jailbroken). Can these tow work together? Should I hold off on uprading Itunes?
  2. owie007

    owie007 New Member

    Joined:
    Nov 29, 2007
    Messages:
    453
    Likes Received:
    7
    Device:
    iPhone 4 (Black)
    7.6 and jailbroken 1.1.2 works... But I suggest that you stick with 7.5

    LOL... I've even got the installer for 7.4.3!

    Please Register or Log in to view images

Share This Page