itunes 7.5 cannot be used error

Discussion in 'iPod touch' started by yourself3082, Aug 26, 2008.

  1. yourself3082

    yourself3082 New Member

    Joined:
    Aug 26, 2008
    Messages:
    10
    Likes Received:
    0
    Device:
    iPod touch
    i want to down grade my ipod from 2.0 to 1.1.4 so i have downloaded and installed itunes 7.5 but when i connect my ipod it say's "the ipod cannot be used because it requiers version 7.7 or later. go to www.itunes.com to download the latest version." what do i do i realy want to jail break it

    Please Register or Log in to view images

  2. mcyo

    mcyo New Member

    Joined:
    Feb 28, 2008
    Messages:
    105
    Likes Received:
    0
    If you want to go back to 1.1.4 you'll have to shift-restore (windows) or option-restore (mac) and then chose 1.1.4 ispw file in itunes 7.5.
    If you want to jailbreak you could stay on 2.0 though and jailbreak it with either PwnageTool 2.0.3 on mac or QuickPwn on windows.

    Please Register or Log in to view images

Share This Page