Itouch versions

Discussion in 'iPod touch 1.1.x Jailbreak' started by Tayg10, Nov 28, 2007.

  1. Tayg10

    Tayg10 New Member

    Joined:
    Nov 28, 2007
    Messages:
    53
    Likes Received:
    0
    Device:
    iPod touch
    What version do i need to jail break? and does anyone know what version comes on the i touches now? I should be getting one from best buy in like 20 or so days.
  2. spoonforknife

    spoonforknife Retired Moderator

    Joined:
    Nov 15, 2007
    Messages:
    6,896
    Likes Received:
    317
    You can jailbreak both. 1.1.2 comes with it. You need to downgrade to 1.1.1, then jailbreak. Then install oktoprep from installer. Upgrade to 1.1.2. Done.

    Please Register or Log in to view images

  3. iPlunder

    iPlunder New Member

    Joined:
    Nov 7, 2007
    Messages:
    178
    Likes Received:
    0
    Why? Why upgrade to 1.1.2?
  4. Danls92

    Danls92 Super Moderator Emeritus Staff Member

    Joined:
    Oct 22, 2007
    Messages:
    5,097
    Likes Received:
    209
    Device:
    iPhone 4 (Black)
    Why not?

    You can do all of the same stuff, and have a less glitchy (not that I noticed any in 1.1.1, but apparently it has less...), and slightly faster iPod.
  5. iPlunder

    iPlunder New Member

    Joined:
    Nov 7, 2007
    Messages:
    178
    Likes Received:
    0
    I'm pretty confident that thats all in peoples heads. I have read alot of no effect.

    And why not? Because, easier jailbreaks for 1.1.1 are much more readily available. And more apps work on 1.1.1 so more noobish people will be able to have an easier time.
  6. Tayg10

    Tayg10 New Member

    Joined:
    Nov 28, 2007
    Messages:
    53
    Likes Received:
    0
    Device:
    iPod touch
    so your telling me that i should downgrade to 1.1.1 then find a jailbreaker for that? is that possible?

    I am a veteran of the psp moding scene, this is all very different.

Share This Page