iTouch lagging like hell

Discussion in 'iPod touch' started by deadlyvirus, Apr 25, 2010.

  1. deadlyvirus

    deadlyvirus New Member

    Joined:
    Jan 2, 2008
    Messages:
    2,157
    Likes Received:
    0
    Device:
    4G iPod touch
    When I mean lag, I mean takes about a minute after hitting the home button to bring up the lock screen. I think the cause is SpringBoard. I have about 5 pages of apps,but now I have 16, most of which have nothing on them. No icon to delete, no blank app, just nothing. I have rebooted, resprung and tried to go to safe mode, but nothing works. Any ideas?
  2. tinyman392

    tinyman392 Super Moderator Staff Member

    Joined:
    Jul 10, 2008
    Messages:
    16,012
    Likes Received:
    1,380
    Device:
    iPhone 6
    1: Hitting the home button doesn't invoke the "lockscreen", it brings you either to home (default) or other specified, jailbroken lib.

    2: 16 Pages is currently not so possible. 11 is. Hold down an icon (any icon) and hit the home button. This should get rid of any pages that are empty.

    3: Turn off some tweaks... THEY USE UP LOTS OF RAM... LOW RAM = LAGGG!
  3. Jarlath

    Jarlath Retired Moderator

    Joined:
    Mar 21, 2008
    Messages:
    2,321
    Likes Received:
    0
    Maybe it's lagging because you're calling it an 'iTouch'.

    Please Register or Log in to view images



    Seriously, though - I'd start with getting rid of all those 'blank' icons (which are probably bookmarks) and make sure that you're not running a lot of stuff in RAM - that can cause slowdowns. Maybe disable all your MobileSubstrate addons. Also look at doing a fresh install and do NOT restore your previous install so you have a clean iPod.

    Beyond that, if you don't have any blank apps there, do you have Iconoclasm installed? If so, try uninstalling it and doing a hard-reboot. There have been issues with that and some other applications which modify the springboard.
  4. deadlyvirus

    deadlyvirus New Member

    Joined:
    Jan 2, 2008
    Messages:
    2,157
    Likes Received:
    0
    Device:
    4G iPod touch
    That's the thing. There are no black apps. And it has 16, I counted. Also, 149MB of RAM free, says SBSettings.
  5. Volcomstone000095

    Volcomstone000095 Banned

    Joined:
    Nov 23, 2009
    Messages:
    262
    Likes Received:
    1
    Device:
    3G iPod touch
    Try to restore. It should work. Also remove MobileSubstrate.
  6. SoBe

    SoBe Banned

    Joined:
    Sep 1, 2009
    Messages:
    3,788
    Likes Received:
    1
    Device:
    2G iPod touch
    Yeah a restore is the best solution.
  7. deadlyvirus

    deadlyvirus New Member

    Joined:
    Jan 2, 2008
    Messages:
    2,157
    Likes Received:
    0
    Device:
    4G iPod touch
    I think it has to do with SBRotator. I disabled that and have 5 pages again, but still lagging. Is there a way to uninstall through SSH? Or run Cydia from SSH? I can't scroll over to it.
  8. SoBe

    SoBe Banned

    Joined:
    Sep 1, 2009
    Messages:
    3,788
    Likes Received:
    1
    Device:
    2G iPod touch
    You can search it in spotlight.
  9. Radish

    Radish Banned

    Joined:
    May 18, 2009
    Messages:
    971
    Likes Received:
    2
    Device:
    iPod touch
    Maybe you'd like to read the rules. A mod like you should know better.
  10. The Poison Woman

    The Poison Woman Banned

    Joined:
    Apr 14, 2010
    Messages:
    35
    Likes Received:
    0
    Oh the irony.
    Anyways, try to limit the amount of processes you have running, etc etc.

Share This Page