Itms protocol vista problem

Discussion in 'iTunes' started by eonflux, Feb 5, 2008.

  1. eonflux

    eonflux New Member

    Joined:
    Jan 15, 2008
    Messages:
    2
    Likes Received:
    0
    Hi guys,

    Im running Vista Ultimate, in admin with iTunes 7.6 installed. I can't seem to finish the account creation process in iTunes because the itms protocol has not been registered. I've tried reinstalling, installing iTunes 7.5. Searching google with no success. There was 1 thread on the apple forums from someone with the same problem. He posted a solution. But i don't seeem to have permission to edit the Registry key for itms while can edit other ones.

    Also there seems to be 0 chatter on this when I search on google.
    When I click an itms link I get this: windows does not know how to handle this protocol. There doesn't seem to be a program associated with it. I also tried the firefox about:config change and it still doesn't work

    Is this me or is this a general VISTA problem.

    Any help on this is greatly appreciated!

    TIA eonflux
  2. APV

    APV Well-Known Member

    Joined:
    Jan 22, 2009
    Messages:
    3,036
    Likes Received:
    69
    Device:
    5G iPod touch
    I have this problem too, but I came accross this with a google search, and there are no answers whatsoever that work, theres the regestry change, the change in "about:config" and all that, it doesnt work for me.

    except I have itunes 8 and firefox 3.

    hmmm.


    I know its an old post but I cant open itunes links which is a big problem.
    AND I KNOW ITS AN OLD POST

    but why make a new topic.

Share This Page