is this the right setup?

Discussion in 'iPhone' started by sphinx1994, Jul 15, 2010.

  1. sphinx1994

    sphinx1994 Member

    Joined:
    Jun 16, 2009
    Messages:
    123
    Likes Received:
    2
    Device:
    iPhone 4S (Black)
    Hi,

    I recently posted (i cant find post):

    "Hello,

    I'm with o2 on pay as you go, and i can send texts to certain people, and other people the send bar goes to about 90% then stops and shortly after a red explaination mark comes up and says

    "Message send failure"

    And when i click the exclaimation mark it says:

    "Your message was not send. Tap try again to send this message."

    Any ideas? "

    and i checked the network settings, and it was on this:

    Please Register or Log in to view images



    it seems to be when i turn mobile data on and keep 3g off, i can send texts to anyone, but this will cost me internet browsing money!

    a fix?
  2. AttackAniPod

    AttackAniPod Banned

    Joined:
    Jul 10, 2010
    Messages:
    627
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    What about turning on 3G?
  3. JJisKing

    JJisKing New Member

    Joined:
    Jul 14, 2010
    Messages:
    248
    Likes Received:
    0
    Device:
    4G iPod touch
    That's what I was thinking.
  4. leadergo

    leadergo Active Member

    Joined:
    Aug 2, 2008
    Messages:
    2,384
    Likes Received:
    6
    That's for data.

    Go to your carrier and tell them about this issue. It could be something with their networks.
  5. jackhawes

    jackhawes New Member

    Joined:
    Apr 4, 2008
    Messages:
    30
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    How long you had your iPhone? Takes about a day for everything to be setup completely i had this problem but only for short term now its all fine.
  6. AttackAniPod

    AttackAniPod Banned

    Joined:
    Jul 10, 2010
    Messages:
    627
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Or reset settings through settings.app
  7. Invisible Man

    Invisible Man Member

    Joined:
    Feb 2, 2010
    Messages:
    206
    Likes Received:
    5
    Device:
    iPhone 4 (Black)
    I had same kind of problem and they told me to do this:

    Settings > General > Reset > Reset Network Settings.

    the device restarts, give it a few seconds and it should work if not contact the support team for O2 and they will put you through to the iPhone specialist team. Or go to a O2 store.

    Hope it helped.

Share This Page