Is there a workaround for installing an app that "requires" 3.1.2 on 3.0?

Discussion in 'iPod touch Firmware 3.0' started by firemblemfreak, Dec 16, 2009.

  1. firemblemfreak

    firemblemfreak New Member

    Joined:
    Feb 6, 2008
    Messages:
    69
    Likes Received:
    0
    Device:
    4G iPod touch
    I have a jailbroken 3.0 and i don't want to have to update to 3.1.2, but one of my favorite games, reign of swords "requires" 3.1.2. Is there any way to fool itunes into installing or it manually installing it myself? (i know how to ssh)

    any help would be appreciated
  2. SmexyPenguin18

    SmexyPenguin18 Active Member

    Joined:
    Dec 27, 2007
    Messages:
    1,749
    Likes Received:
    0
    Device:
    3G iPod touch
    In the info.plist of every app there will be a required firmware. Change it to 3.0, but you might get some compatibility problems. Also, Why don't you just update to 3.1.2?
  3. firemblemfreak

    firemblemfreak New Member

    Joined:
    Feb 6, 2008
    Messages:
    69
    Likes Received:
    0
    Device:
    4G iPod touch
    It is a pain to back up all my data, and then restore, and then re-jailbreak on a new firmware, and then re-setup all my stuff which includes an INAV theme
    ------------------double post merged------------------
    also how do i access the info.plist file, it is an app store app and all i see when i click show in finder is a .ipa file
  4. SmexyPenguin18

    SmexyPenguin18 Active Member

    Joined:
    Dec 27, 2007
    Messages:
    1,749
    Likes Received:
    0
    Device:
    3G iPod touch
    You might as well get it out of the way. It's really not that bad.
  5. firemblemfreak

    firemblemfreak New Member

    Joined:
    Feb 6, 2008
    Messages:
    69
    Likes Received:
    0
    Device:
    4G iPod touch
    thats what i'm thinking...
    just wanted to see if there was an easy work-around
  6. SmexyPenguin18

    SmexyPenguin18 Active Member

    Joined:
    Dec 27, 2007
    Messages:
    1,749
    Likes Received:
    0
    Device:
    3G iPod touch
    Every once in a while I start from a clean restore and do everything over.
  7. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S

    me too. but ive decided not to jb my 3GS til theres untethered jb
  8. Steaps

    Steaps New Member

    Joined:
    Oct 24, 2007
    Messages:
    5,074
    Likes Received:
    41
    Device:
    iPod touch
    It is truely a pain to press a button and watch iTunes do it all for you. Let it run while you sleep.
  9. ISkateOn

    ISkateOn New Member

    Joined:
    Mar 5, 2009
    Messages:
    135
    Likes Received:
    0
    Device:
    iPhone 3GS (Black)
    besides having to put all your themes and all back onto there. imo its a pain but i guess its not ALL that bad
  10. fyvel

    fyvel Active Member

    Joined:
    Dec 3, 2007
    Messages:
    1,545
    Likes Received:
    9
    Device:
    iPod touch
    go into cydia and use fwchanger.. and change the number from 3.x to 3.1.2...

    Please Register or Log in to view images

    but upgrading is 760598794837 times better..

    Please Register or Log in to view images

Share This Page