Is my iPod touch broken?

Discussion in 'iPod touch' started by glassesworth, May 23, 2009.

  1. glassesworth

    glassesworth New Member

    May 23, 2009
    Likes Received:
    Okay, so I had firmware 1.1.1 for ages and it was jailbroken. I decided I didn't want it like this anymore, seeing as I never ever used the jailbroken applications in the first place. I only used it for music. Then I updated it to 1.1.5 through iTunes. Once it was finished, the problems came up. iTunes does not read my iPod anymore... I tried plugging it into a different computer but it says it's a camera?

    Please Register or Log in to view images

    I tried these things, please don't suggest them;

    Reinstalling iTunes. (I have the most recent version, kthnx.)
    Rebooting my computer
    Rebooting my iPod (I did the button reset thing too, you know, holding both buttons for a while until an apple logo show up?)
    I tried uninstalling the hardware from my computer through.. devicemanager? My computer is Dutch, sorry. Then once I did this, it recognised it as a camera so I updated the drivers and what not. Still does not work.

    If it help, I tried it on two Windows Vista computers. Don't suggest trying it on a Mac because no one has a Mac where I live.

    The iPod itself still works. I can turn it on, etc. Just I can't click on "music" or "itunes". It shows a blank screen for a few seconds before going back to the dock.

Share This Page