Is it worth it to downgrade from 2.0.x for a while?

Discussion in 'iPod touch 1.1.x Jailbreak' started by Noisemaker, Sep 8, 2008.

  1. Noisemaker

    Noisemaker Banned

    Joined:
    Aug 27, 2008
    Messages:
    410
    Likes Received:
    0
    I am currently running 2.0.2 jailbroken firmware. However, as I'm sure many of you already know, there is a LOT less compatibility, and many apps don't run as well.

    Is it worth it to "downgrade" to 1.1.4 or 1.1.5 to get emulators, iSlsk, and the various other apps that are still WIP's for 2.0.x firmware? I don't have a lot of apps from the app store, and I could always upgrade again later to 2.0.x.

    If I downgrade, will all of this stuff still work, or is it more than just the 2.0.x firmware that's making it incompatible now? Are there still sources for these in Cydia and Installer?
  2. Felix da Fox

    Felix da Fox New Member

    Joined:
    Jan 25, 2008
    Messages:
    50
    Likes Received:
    0
    Device:
    iPod touch
    personally i'd would stay at 1.1.4 just because of the incompatibility issues. It sucks for me cus im doing an anatomy course and i really would like Netters Anatomy but its only on 2.x.x

    Please Register or Log in to view images



    But for everything else, mxtube, islsk, pockettouch, tunewiki etc. is just outweighs it

    Please Register or Log in to view images

  3. Gitykins

    Gitykins Banned

    Joined:
    May 16, 2008
    Messages:
    3,760
    Likes Received:
    1
    LMFAO! WTF are you on?

    MxTube, PocketTouch, TuneWiki are ALL on 2.x. iSlsk is probably going to be released within the month. You need to catch up.

    Also, to OP, it is nowhere near worth it.
  4. one1

    one1 New Member

    Joined:
    Jan 30, 2008
    Messages:
    54
    Likes Received:
    0
    Device:
    2G iPod touch
    I have a phone on 2.1 and a touch on 1.1.4 and I don't think I could be without either of them. 1.1.4 offers some great things, and since the apps have been around since the 1.0 days they are what we know as "THE jailbreak apps". They are the familiar constants that have always been - without the choking of the SDK sandbox rules. I love 1.1.4 and everything about it. I wouldn't want to be without it.

    That said, I have 647 app store apps, and I swap them around on my phone whenever I get the itch and the polished SDK apps are awesome in their own way. Much more technical and complicated, much more fun games. Just kinda got that noose around the neck feeling.

    With the 1st gen pod becoming so cheap, grab a used one for $150 and have the best of both. I don't think 2.0 will ever be as great as 1.1.4 in some ways, and I don't think 1.1.4 will ever be as great as 2.0 in other ways. Personally, I don't want to be without either, so I bought a touch and hacked the shot out of it for my 1.1.4 needs.

Share This Page