Is FW 1.1.3 too old?

Discussion in 'iPod touch' started by nelson480, Nov 1, 2008.

  1. nelson480

    nelson480 New Member

    Joined:
    May 3, 2008
    Messages:
    303
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I still have 1.1.3 on my touch and i was wondering Im stuck in the prehistoric days of the jailbroken touch. Hasn't been any activity or anything new on installer 3.1 in a LONG TIME. I have alot of apps that now cannot be replaced if i upgraded and have no where to start if i wanted to upgrade to 2.0 and so on. Please give me your opinion.

    Please Register or Log in to view images

  2. exit1010

    exit1010 Well-Known Member

    Joined:
    Dec 30, 2007
    Messages:
    4,812
    Likes Received:
    48
    Device:
    4G iPod touch
    ummm... where have you been dude... 1.1.X is dead... installer is dead... cydia is the new deal for firmware 2.1

    so update your ipod. and jailbreak it with quick pwn. not ziphone or winpwn but quickpwn.
    you can install installer but it is still in beta since the last 7 months...
  3. nelson480

    nelson480 New Member

    Joined:
    May 3, 2008
    Messages:
    303
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    I dont wanna lose all my stuf tho

    Please Register or Log in to view images

    itll be a hard decision since i guess everone's abandoned installer, which was here be4 cydia. Actually i do have cydia, as a backup for when installer is down...
  4. jlgm25

    jlgm25 Well-Known Member

    Joined:
    Nov 1, 2008
    Messages:
    3,302
    Likes Received:
    28
    Device:
    4G iPod touch
    why like installer? you have cydia dude. its the new installer.. somewhat like it i guess.
  5. ipNinja

    ipNinja New Member

    Joined:
    Mar 5, 2008
    Messages:
    1,209
    Likes Received:
    5
    Device:
    iPhone 3GS (White)
    1.1.3 is the new black
  6. BadKarma

    BadKarma Banned

    Joined:
    Jul 16, 2008
    Messages:
    4,037
    Likes Received:
    0
    Device:
    iPod touch
    1.1.3 IS SO OLD. That came out in what, 2007?

    This is why Saurik said "back in the day" that Cydia is going to be the iPhone's future.
  7. sjleworthy

    sjleworthy New Member

    Joined:
    Jan 4, 2008
    Messages:
    780
    Likes Received:
    0
    Device:
    iPad w/ 3G
    i recently upgraded to 2.1 after a year on 1.1.4

    to be honest, best move i made. dont worry about loosing your apps as not only will you soon forget what you lost in the first place, but with the advent of the App Store you wont even care. Downloading and installing from a MASSIVE choice of stuff on your Touch has never been so much fun.
    I'm staying legit on my un-broken 2.1 firmware, and am really enjoying it. it really has come of age. cant wait for the future

    Please Register or Log in to view images

  8. nelson480

    nelson480 New Member

    Joined:
    May 3, 2008
    Messages:
    303
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Like i said i have cydia but it seems like theres nothing on it...
  9. nelson480

    nelson480 New Member

    Joined:
    May 3, 2008
    Messages:
    303
    Likes Received:
    0
    Device:
    iPhone 4 (Black)

    Attached Files:

  10. x6blues

    x6blues New Member

    Joined:
    Dec 13, 2007
    Messages:
    2,879
    Likes Received:
    113
    2.x offers many overall improvements, updated interface with apps, and much more.

    As has been said, 1.x/Installer have been abandoned for 2.x/Cydia which is the reason why all the applications you have are available on 2.x or have a superior replacement such as is the case with Summerboard, 2.x offers Winterboard. Then, new applications and hacks.

    Then, the AppStore. So many opportunities even if you do not wish to buy applications. Browse the free apps sections and you'll see.

    Overall it is frankly the better switch. Updated, modern, and a sh*t load of new features....it's gotta be great.

Share This Page