Is 2.0 update kit necessary?

Discussion in 'iPod touch Firmware 2.X' started by gaore, Jul 17, 2008.

  1. gaore

    gaore New Member

    Joined:
    Jul 17, 2008
    Messages:
    7
    Likes Received:
    0
    I just bought an iPod touch, with 1.1.5 firmware.

    Do you think 2.0 update kit is necessary? or I should wait for jail break? Thanks.
  2. HAL9000

    HAL9000 Banned

    Joined:
    Jul 13, 2008
    Messages:
    82
    Likes Received:
    0
    Well it would be illegal to obtain 2.0 without purchasing it. I would go ahead and buy it if I were you.
  3. nothernhorspowa

    nothernhorspowa New Member

    Joined:
    Dec 20, 2007
    Messages:
    61
    Likes Received:
    0
    You can get 2.0 w/out buying it if you have issues with your iTunes program..... go check the links around here for "legally getting 2.0". I had 1.1.2 jailbroken with apps, and I really like the apps in the AppStore. Only thing I don't like if the fact that I can't customize how it looks yet :/ Like skins, themes, lock screes, ect.... that is a big thing for me, so I'm going to wait and see how Customize 2.0 comes along, if nothing comes out soon I will downgrade.
  4. mirco

    mirco New Member

    Joined:
    Feb 5, 2008
    Messages:
    3
    Likes Received:
    0
    You can try to return the iPod to the seller arguing that they are selling obsolete models and you are not satisfied with your purchase. They may also offer you exchange or discount - who knows?

Share This Page