IPOodwon't turn on or charge after jailbreak.

Discussion in 'iPod touch' started by moodmuzik, Apr 30, 2009.

  1. moodmuzik

    moodmuzik New Member

    Joined:
    Apr 30, 2009
    Messages:
    1
    Likes Received:
    0
    I just recently (Last Friday) hacked my ipod 2G (FW 2.2.1) and it worked perfectly. I used redsn0w. The same day and the next it was orking perfectly fine, charging, getting noticed on the computer and all.

    So Sunday came i went to work and came home and my IPod was off, so i decided to try to charge it because it wasn't turning on.

    I have an outlet > USB charger but that didnt work so i thought that the USB wall charger wasn't working so i decided to try to charge it on my computer.

    No luck at all nothing lights up the computer doesnt recognize it, and my ipod does not turn on at all or chage anywhere i try to charge it. Itunes doesnt recognize it either.

    I tried leaving it overnight to charge but no lick there either..

    So anybody know whats going on?.. is it the hack, or do you think it's more of a hardware problem.

Share This Page