iPod won't boot after "libhide" update

Discussion in 'iPod touch' started by JohnGore, Sep 5, 2009.

  1. JohnGore

    JohnGore New Member

    Joined:
    Mar 15, 2009
    Messages:
    56
    Likes Received:
    0
    Device:
    4G iPod touch
    So this morning I turned on my ipod went to cydia and found there was an update for "categories" and "libhide", So I went ahead and updated having all my apps hidden for my whitoken theme, It gave me all these words saying "checking to see if hidden,rehiding,deleting entry' all those things, That took about 10 minutes when it came to the respring it got stuck, So I did a hard reboot and it got stuck in the apple logo. So now my iPod won't boot and probably my only option now is to restore. For some odd reason im still able to SSH in, So I want to know if I can remove some troublesome file to get me from restoring.
  2. aLlamaWithARifle

    aLlamaWithARifle New Member

    Joined:
    Aug 14, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    Same here so I did a bit of googling and found loads of people are having this problem, best thing to do is if you can get into Cydia and search for libhide and remove it if not some people have said ssh into your phone and remove libhide that way.
  3. mark1985

    mark1985 New Member

    Joined:
    Dec 28, 2008
    Messages:
    178
    Likes Received:
    0
    Device:
    4G iPod touch
    i updated, too!
    Stuck in bootloop
    any one knows how to solve that problem?

    ------------------double post merged------------------

    DONT RESTORE its seems there is a solution


    from
    http://thebigboss.org/2009/09/05/lib...#comment-11791
    i havent tried because i donĀ“t want to mess up even more by deleting wrong files
    can anyone confirm that this method works?
  4. aLlamaWithARifle

    aLlamaWithARifle New Member

    Joined:
    Aug 14, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    Well I managed to break the boot loop by just holding down the power button for like 30 seconds and eventually my ipod came too and was able to get into cydia and uninstall libhide but guess what... that uninstalls sbsettings and categories so when you do that all your icons appear on your springboard. Well atleast I can use it

    Please Register or Log in to view images



    I then shhed my phone and deleted the libhide folder and nothing went wrong so you should go for it.

    Not sure what to do now... wait for a new version of libhide where this problem doesn't exist? Or is there a way to install the old version of libhide?
  5. JohnGore

    JohnGore New Member

    Joined:
    Mar 15, 2009
    Messages:
    56
    Likes Received:
    0
    Device:
    4G iPod touch
    I already restored gah
    should have been more patient.
  6. red_5

    red_5 Member

    Joined:
    Nov 19, 2008
    Messages:
    756
    Likes Received:
    0
    If you do have to restore there are ways to backup your device via ssh if you so desire. See my jailbreak guide (linked in my signature)
  7. mark1985

    mark1985 New Member

    Joined:
    Dec 28, 2008
    Messages:
    178
    Likes Received:
    0
    Device:
    4G iPod touch
    it works!
  8. JohnGore

    JohnGore New Member

    Joined:
    Mar 15, 2009
    Messages:
    56
    Likes Received:
    0
    Device:
    4G iPod touch
    Which file did you delete? all I see is

    sbsettings.dylib and

    sbsettings.plist
  9. MuseFan288

    MuseFan288 New Member

    Joined:
    Jun 4, 2009
    Messages:
    357
    Likes Received:
    0
    Device:
    3G iPod touch
    i updated the libhide for the same thing and didnt get this problem
    but everything i had in categories folders had a clone outside of the folder and when i deleted one both got deleted but i fixed it
  10. asg31

    asg31 New Member

    Joined:
    Jun 23, 2009
    Messages:
    65
    Likes Received:
    0
    Device:
    2G iPod touch
    fck to late i restored over night

Share This Page