iPod update or restore results in DFU mode

Discussion in 'iPod touch' started by dragonfire, Oct 8, 2009.

  1. dragonfire

    dragonfire New Member

    Aug 23, 2009
    Likes Received:
    2G iPod touch
    Hi all,

    2 issues I need help with.

    1) Whenever I try to update my iPod 2g, (eg. from OS 2 to OS3 and from OS3 to OS3.1) it downloads the new firmware, then transfers to the device, then leaves me in DFU mode. Restoring performs a complete restore, then also leaves me in DFU mode.

    I called Apple support, and despite reinstalling iTunes, deleting temp files, and creating a new user, I kept getting the same result. They blamed it on Vista.

    I discovered I could install the firmware on a different computer (XP, 6 years old, slow), then restore my backup data on my Vista PC.

    I'm afraid to update again or to jailbreak (when one is available). Each time this happens, it's a struggle to get it working again.

    2) Last time I restored my data, I encountered widespread corruption. My Apps wouldn't transfer (it claimed it couldn't find them), then they did transfer but didn't work properly. My Videos and music transfered, but with corruption within each file (the video's go blank for a few seconds sporadically). These videos worked fine before the restore. I can live with this, but it's really frustrating.

    SO, I need to know if this is a problem with my iPod, so I can get it replaced while its still under warranty.

    iPod 2g OS3.1
    Vista comp with latest iTunes 9.

    Is there any way I can fix my problems?

    Thanks so much! You guys are awesome.
    ------------------double post merged------------------
    WHen I try to re-sync my videos, I get an error: "The disk cannot be read from or written to". Has anyone else seen this?

Share This Page