IPoD Touch won't update!!!!

Discussion in 'Introduce yourself' started by JHeredia18, May 11, 2010.

  1. JHeredia18

    JHeredia18 New Member

    Joined:
    May 11, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    iPod touch
    My iPod Touch 1st gen is not updating to any software. I am running on 1.1.5 which is super old but when I try to updat, it says "error 1604". I believe it was jail broken before but have since restored it. Does restoring clear everything because my screen is also dim and there are problems with jail broken iPod touches and screen brightness. I have tried 2.0 also 3.1.3 but have come up short. I need legit cites to download and install 2.0 at least to download apps. Can I also get some instruction plz as I am new to all of this.
  2. Tkf1

    Tkf1 Community Development Staff Member

    Joined:
    Oct 12, 2009
    Messages:
    17,397
    Likes Received:
    2,488
    Device:
    iPad mini
    Lastest itunes version?
    Pay for the update.
  3. narwal13

    narwal13 Active Member

    Joined:
    Oct 12, 2009
    Messages:
    3,070
    Likes Received:
    6
    Device:
    5G iPod touch
    you need the latest itunes version and 3.1.3 the latest firmware. buy the firmware!

    Please Register or Log in to view images

  4. JHeredia18

    JHeredia18 New Member

    Joined:
    May 11, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    iPod touch
    I did...and I have iTunes 9...how can u check again what the firmware i downloaded and what itunes I have again?
    ------------------double post merged------------------
    I just checked and have 9.1.1 which is the current version and I also bought the firmware
  5. iLanon

    iLanon New Member

    Joined:
    May 13, 2010
    Messages:
    6
    Likes Received:
    0
    Use another USB port... simple solution will work, since you have the newest itunes version..

Share This Page