Ipod Touch Update - Gone majorly wrong

Discussion in 'iPod touch' started by Connor06, Feb 7, 2010.

  1. Connor06

    Connor06 New Member

    Joined:
    Feb 7, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    2G iPod touch
    I recently tried updating my iPod touch to the newest firmware as iTunes kept on bugging me about updating, Today i did and while the update was nearly done. It failed. After that ive tried turning my iPod on and it wont turn on at all. Battery hasnt run out, ive tried everything. Holding the power button and home button for 10 seconds, Nothings working...

    Any ideas?

    Thanks so much

    -Connor
  2. Sussex88

    Sussex88 New Member

    Joined:
    Feb 8, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    iPod touch
    Same here

    The same thing is happening with mine, Can anybody Help?
  3. Shawa

    Shawa Super Moderator

    Joined:
    Jan 31, 2009
    Messages:
    3,188
    Likes Received:
    22
    Device:
    Nexus 4
    Power + Home 10 secs
    Home 30 secs

    Restore
  4. Cl8rs

    Cl8rs Active Member

    Joined:
    Apr 20, 2009
    Messages:
    1,760
    Likes Received:
    1
    Device:
    2G iPod touch
    Or plug in the iPod and hold the Home button until you see the "Connect to iTunes" screen.

    @Shawa: AWESOME AVATAR!
  5. Sussex88

    Sussex88 New Member

    Joined:
    Feb 8, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    iPod touch
    I have done that but still nothing happens.
  6. jimmyv13

    jimmyv13 New Member

    Joined:
    May 9, 2009
    Messages:
    13
    Likes Received:
    0
    Device:
    3G iPod touch
    Is this happening with the 3.1.3 update?
  7. Connor06

    Connor06 New Member

    Joined:
    Feb 7, 2010
    Messages:
    2
    Likes Received:
    0
    Device:
    2G iPod touch
    Yeah i think its the 3.1.3 update

    Please Register or Log in to view images

  8. jmwerkus

    jmwerkus Active Member

    Joined:
    Apr 9, 2009
    Messages:
    3,030
    Likes Received:
    17
    Device:
    iPhone 5S
    i restored to a custom 3.1.2 fw on 3GS and it went fine

Share This Page