iPod Touch stuck on restore AGAIN

Discussion in 'iPod touch' started by axel006, Jul 13, 2009.

  1. axel006

    axel006 New Member

    Jul 1, 2009
    Likes Received:
    2G iPod touch
    Okay, I've jailbroken my ipod before and got Cydia on it and everything, but I had to restore the iPod in order to do this. So all my songs are gone. Now my sister wants all those songs back, so she reinstalls all her songs back inside. The only problem is that Cydia was deleted for some reason. I'm not sure, but I think she upgraded my 2g version 2.2.1 iPod Touch to 3.0, and that must of deleted Cydia. So I'm trying to jailbreak my iPod again with Redsnow, but this time, it just gets stuck on the "Downloading Jailbreak Data..." screen, and then all of a sudden goes to recovery screen. I don't want to recover it especially since my sister just finished downloading all those songs back, so I keep trying to use Redsnow to jailbreak but it keeps getting stuck on the "Downloading Jailbreak Data..." screen. In the end, I just decide to recover it. But to my disbalieve, I get the horrid 16XX errors. Now, there's absoutely no way I know of right now to get the iPod back to normal. I even tried jawcl's method of iBoot to get it back to normal, but I can never even get the .exe file opened even if I try in DFU mode. It would be really nice if any of you could help.

    Please Register or Log in to view images

  2. Swift

    Swift Member

    Sep 19, 2007
    Likes Received:
    iPhone 5 (White)
    Have you tried to boot into DFU Mode, open iTunes, and shift + click on Restore whereupon you select your 3.0 firmware? Is it after taking these steps that you get the 16-- errors?

    Also, never upgrade to a new firmware from a jailbroken status. Always DFU restore to the new firmware, then jailbreak.

    Also, some 16-- errors are from not having the latest iTunes. Uninstall the iTunes you have, and go to iTunes.com and download and install that.

Share This Page