Ipod touch stuck in recovery mode, wont restore

Discussion in 'iPod touch' started by bolrugard, Apr 4, 2009.

  1. bolrugard

    bolrugard New Member

    Joined:
    Feb 12, 2009
    Messages:
    6
    Likes Received:
    0
    Device:
    2G iPod touch
    Well my friend tried jailbreaking his ipod and now I have been trying to fix it... Well its in recovery mode and itunes finds it... it will restore... sometimes the bar stops halfway and sometimes full! It says the ipod has been reseted and it should boot up but it takes few seconds then goes into recovery mode can not figure this out!! PLEASE HELP ME!!

    -Tried restoring in dfu
    -Tried restoring regular firmware
    -Tried restoring with custom firmware
    -Tried restoring with NOR only (changes both logos just wont boot)

    Please this is so annoying!!!!!!!!!!!!!!!!
  2. muffinza192

    muffinza192 Active Member

    Joined:
    Feb 2, 2009
    Messages:
    231
    Likes Received:
    28
    Device:
    iPhone 4 (Black)
    After the restore and its in recovery mode did u try putting it into DFU again then restoring? just making sure


    and if that doesn't work since uve tried allthe restoring tactics and it only goes into recovery mode...i think u would be able to bring it to the apple store, they wont be able to tell if u tried to jailbreak it or not.

Share This Page