iPOD Touch on an older eMac?

Discussion in 'iPod touch' started by biggame, Dec 27, 2008.

  1. biggame

    biggame New Member

    Joined:
    Dec 27, 2008
    Messages:
    1
    Likes Received:
    0
    I purchased an iPod Touch for use with an older (5 years old?) eMac. The eMac runs on a Power PC G4 (1.1) but only has 256 MB or memory - which I believe is not enough for the Touch. Also an issue, the OS is 10.3.9 which I believe is also not current enough.

    My questions: Do I need to add memory and is this easy and inexpensive? Also, can I upgrade to the Leopord OS and will these two items allow me to successfully use the iPod Touch with this older Mac? Thanks for any help!

    Please Register or Log in to view images

  2. BaseballMVP755

    BaseballMVP755 Banned

    Joined:
    Dec 1, 2008
    Messages:
    624
    Likes Received:
    0
    yea, u'll proably need more than this, but u can try. download itunes and connect, and hopefully u have enough memory for the apps and music. if not, u should probably buy an external harddrive or something like that
  3. Der-Kleine

    Der-Kleine Active Member

    Joined:
    Jun 24, 2008
    Messages:
    2,314
    Likes Received:
    24
    Device:
    Samsung Galaxy S2
    Does iTunes 8 run on it?
    If yes, then everything shuld work.
  4. Joe Rossignol

    Joe Rossignol Community Manager Staff Member

    Joined:
    Jan 9, 2008
    Messages:
    11,500
    Likes Received:
    1,268
    Device:
    iPhone 5 (Black)
    No, of course iTunes 8 won't run on an old eMac. The computer doesn't meet iTunes requirements so you'll need to get more memory (RAM) like you mentioned for your eMac.

    It's not a hard process. You just need to buy a stick of RAM (I would recommend getting 1GB) that matches your eMac. But I would check if there's another slot inside your computer for an additional stick of RAM/memory first.

    Also, you can't upgrade the OS to Leopard on an eMac because it falls well below the minimum system requirements for OS X 10.5 (Leopard).
  5. Imitation

    Imitation New Member

    Joined:
    Dec 27, 2008
    Messages:
    113
    Likes Received:
    0
    Device:
    iPod touch
    It won't be able to work on v10.3.9. On Apple's website, the minimum version is 10.4.10. So you're SOL when it comes to the operating system requirement.
  6. Clownassasin

    Clownassasin New Member

    Joined:
    Feb 17, 2008
    Messages:
    2,546
    Likes Received:
    13
    Device:
    2G iPod touch
    oh your on tiger kool
    i was tryin to get tiger on my dads old macintosh powerbook g3 but it couldnt

    Please Register or Log in to view images

Share This Page