iPod Touch not working at all

Discussion in 'iPod touch' started by Nokiemens, Apr 19, 2010.

  1. Nokiemens

    Nokiemens New Member

    Joined:
    Jul 21, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    I've had my iPod touch for a year or so, and it's been jailbroken for most of its life. A while ago, I updated several of the programs on it. It told me to restart the springboard, so I did. But after a while, it crashed without warning. It started rebooting and rebooting, on and on and on without end. I let the battery run dry, and after it did, I tried booting again, like any normal person. It kept rebooting, so I let it run dry again. Now recently, I tried to restore it to the original software, by putting it into DFU mode, and using iTunes once again. But after it gets to the "preparing iPod for restore" it hangs up, and the iPod is stuck with the Apple, Inc. logo on the front. I let it rest for a while, but it didn't get anywhere at all. So I yanked it, and it shut off normally. Now, it gives me the traditional warning that my iPod is in restore mode. Any suggestions?

Share This Page