iPod Touch MC Model 3G 8GB Query

Discussion in 'iPod touch' started by oreo27, Apr 13, 2010.

  1. oreo27

    oreo27 New Member

    Joined:
    Apr 12, 2010
    Messages:
    8
    Likes Received:
    0
    What firmware does this certain model use? Once and for all, can someone finally prove to me that this uses a 3G or 2G firmware. Thanks.
  2. ibizaGTi

    ibizaGTi New Member

    Joined:
    Dec 19, 2009
    Messages:
    638
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    It can use either. The 3rd gen is identical (apart from the BootROM) to the wnd gen hardware wise. You can use the 3rd gen firmware, but you cannot downgrade with it.
    You can use the 2nd gen firmware to downgrade the 3rd gen if you need to.
  3. oreo27

    oreo27 New Member

    Joined:
    Apr 12, 2010
    Messages:
    8
    Likes Received:
    0
    Okay. Thank you for your response. When the iPod of this certain type ships, what firmware does it use?

    I have downgraded mine to the 2G 3.1.2 for a jailbreak. It was successful and I can successfully go back and forth between 2G 3.1.2 and 3.1.3.

    However, when I try to update using 3G 3.1.3 firmware, I get the error "this firmware is not compatible with your device" or something similar to that. Any ideas?
  4. ChrisL

    ChrisL Well-Known Member

    Joined:
    Jul 26, 2008
    Messages:
    8,704
    Likes Received:
    159
    I guess it is only compatible with 2G firmware, which kind of makes sense since it technically has the hardware of a 2G iPod.
  5. oreo27

    oreo27 New Member

    Joined:
    Apr 12, 2010
    Messages:
    8
    Likes Received:
    0
    okay, can anyone else confirm this? With someone with a Vanilla iPod of this model who tried to restore look for the ipsw if it says 2,1 or 3,1?

    You can find it by going to appdata folder. On windows run %appdata% It's somewhere in there.
  6. ibizaGTi

    ibizaGTi New Member

    Joined:
    Dec 19, 2009
    Messages:
    638
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    When i have restored in the past (to 3.1.2), i have used the third gen firmware. However, Cydia shows my device as running the second gen firmware as the devices are the same.
    If you want the 3rd gen firmware back on your device (which will run exactly the same as the 2nd gen one), you just need to do a DFU restore on your device.
  7. oreo27

    oreo27 New Member

    Joined:
    Apr 12, 2010
    Messages:
    8
    Likes Received:
    0
    i have tried DFU restore with my iPod (Yes, I know that DFU is the one with the screen completely turned off) with a 3G firmware. It still says firmware is not compatible with the device. do you have first hand experience with this?
  8. nojbonmyip:(

    nojbonmyip:( New Member

    Joined:
    Jan 30, 2010
    Messages:
    79
    Likes Received:
    0
    Device:
    3G iPod touch
    IT USES A 3G FW THATS Y ITS 3.x
  9. ChrisL

    ChrisL Well-Known Member

    Joined:
    Jul 26, 2008
    Messages:
    8,704
    Likes Received:
    159
    Lol, what?
  10. oreo27

    oreo27 New Member

    Joined:
    Apr 12, 2010
    Messages:
    8
    Likes Received:
    0
    okay, what?
    ------------------double post merged------------------
    i'm upping this. any clue?

Share This Page