Ipod touch bricked? Not even DFU is working. Help please

Discussion in 'iPod touch' started by iMikerz, Sep 3, 2009.

  1. iMikerz

    iMikerz New Member

    Joined:
    Sep 3, 2009
    Messages:
    1
    Likes Received:
    0
    Device:
    2G iPod touch
    I had just downloaded FivelRows from cydia for my ipod touch, after it had been jailbroken for nearly a month now when the screen froze, went weird and then turned off. Similar things had happened before but i managed to fix them with 1 click boot, but now my computer doesn't recognize my ipod touch 2g even in DFU mode. It makes a beep when i hold home+lock for 10 seconds and then another beep after I let go of lock and hold home for 10 seconds, but the beep sounds different to how it used to, it sort of sounds like dududum instead of bardum.

    I've tried restarting computer, reinstalling itunes twice (the first time i reinstalled it recognized it but stopped working half way through booting my ipod) tried DFU mode with different time spaces about 20 times at least, i've looked through everywhere on google and here and haven't found a fix that works, is my iPod really bricked? I've only had it for less than a month

    Please Register or Log in to view images



    It might be due to the way i jailbroke it, as I have had quite a few problems so far. I used this method to jailbreak: http://www.youtube.com/watch?v=HFEk_nt4ZtM

    EDIT: I managed to restore my ipod and finally fix it after hours of trying. I had to use a different computer which i tried, but it had errors updating the firmware, after that i tried different things and found http://www.ifans.com/forums/showthread.php?t=42102 after i followed the instructions, my ipod was recognized in DFU and i could restore the firmware

    Please Register or Log in to view images

    I will leave this here so people know how to fix their ipod if it happens

    Any help would be appreciated so much, thankyou

    Please Register or Log in to view images

Share This Page