iPod Touch 3g/3rd gen stuck in DFU mode

Discussion in 'iPod touch' started by ipodtouchn0ob, Apr 14, 2010.

  1. ipodtouchn0ob

    ipodtouchn0ob New Member

    Apr 14, 2010
    Likes Received:
    Hello IPT Fans.

    I tried to find information on youtube, google, and many other websites for a couple of weeks... no success.

    So, basically, my iPod touch 3rg gen 64gb came with the firmware 3.1.1, and I jailbroke (tethered) right after I took it out of the box.

    Okay, the problem is, it reboots RANDOMLY sometimes so I have to jailbreak again and again with blackra1n. And sometimes (random), when it reboots, it becomes SO FREAKING slow and glitched (like the power and home button works randomly and crazy)... sounds frustrating right?

    So I guess it is a firmware problem or something, so I tried to shift+restore with 3.1.2 but it doesn't restore and some error shows up on iTunes.

    And today I tried to put it in DFU mode and shift+restore, but the same error happened... now I'm stuck in DFU mode and I don't want to restore it to 3.1.3 (or should I?)... WHAT SHOULD I DO?

    Should I just restore to 3.1.3 and see if it still slow and glitched, and if it is, take to apple store and ask for a new ipod? will they give me a new one with 3.1.2 installed

    Please Register or Log in to view images


    I'm doomed, because me and 2 friends ordered ipods online (all 3g and 64gb), and just mine is slow and glitched (random reboots and slow)..


    oh, btw I'm kinda newbie..

    Thanks a lot..!

Share This Page