iPod touch 3.0 Firmware Problem

Discussion in 'iPod touch' started by d3xterity, Jun 21, 2009.

  1. d3xterity

    d3xterity Member

    Jun 17, 2009
    Likes Received:
    iPhone 4 (Black)
    I recently jailbroke a 3.0 firmware ipod touch 2g. It worked until I used winterboard to change the theme. My iPod touch turned off and then it kept turning back off when I turned it on. I restored the ipod touch back to the 3.0 firmware. I then decided to jailbreak it again with redsn0w and now it was unsuccessful. It became stuck at downloading jailbreak data. I put my ipod touch into dfu mode and decided to restore it back to 3.0 firmware. While it was restoring, the progress bar went to 100%, but it just stays there with my computer saying waiting for ipod. I tried again and again, but it still stays the same. Now I cant restore it to any firmware version. When I turn it on it shows me the picture to connect to itunes. After I connect to itunes and try to restore it shows me error 20. Help?

Share This Page