Ipod Touch 2g wifi broke after 3.0 and still in 2.2.1!

Discussion in 'iPod touch' started by Chris123643, Aug 28, 2009.

  1. Chris123643

    Chris123643 New Member

    Joined:
    Aug 28, 2009
    Messages:
    8
    Likes Received:
    0
    Device:
    2G iPod touch
    Ok, so i downloaded 3.0 and used shift restore to update it, that went well... then i decided to jailbreak it 5 minutes after that. That went ok too, but i noticed that my connection to the wifi was weaker, and cut out. I decided to restore but the wifi wouldn't connect at all!... i thought if i restore back to 2.2.1 it would work again (as it always worked fine) i downloaded the 2.2.1 firmware and restored to that successfully, but still no wifi connection, it appears as one bar signal and when i enter the password correctly it just says im unable to connect! So im left with no options on what to try, can i still take it back to apple considering i jailbroke it?... what shall i try next?!
  2. DarkWrath

    DarkWrath Active Member

    Joined:
    Apr 17, 2009
    Messages:
    1,218
    Likes Received:
    0
    Device:
    4G iPod touch
    3.0 has known WiFi problems. Enter DFU & restore to 2.2.1 but do not restore from backup. Also, where exactly did you 'download' this firmware? Downloading firmware that costs money from an alterior source is ilegal and against forum rules.
  3. n_848

    n_848 New Member

    Joined:
    May 30, 2009
    Messages:
    30
    Likes Received:
    0
    Device:
    2G iPod touch
    could be the router too
    if you stop using wifi in your ipod it loses signal
    all i do is unplug and then plug it back in
  4. cmjdjm1

    cmjdjm1 New Member

    Joined:
    Sep 19, 2008
    Messages:
    37
    Likes Received:
    0
    Device:
    2G iPod touch
    ya, i was gonna say its odd that theres no signal in both firmwares. its not likely that firmware is going to kill the Wifi, so I'd try resetting your router and see if that helps. Im using 3.0 and Ive had no Wifi problems at all at home or anyone elses houses either.
  5. Chris123643

    Chris123643 New Member

    Joined:
    Aug 28, 2009
    Messages:
    8
    Likes Received:
    0
    Device:
    2G iPod touch
    just an update guys... thanks for the replies, ive only just seen them and i have sorted it out but your comments would have helped me fix the problem! i didn't think it would be the router because i didn't understand why it worked fine before, then not after. But i removed all the security settings on the router and it worked perfect! put the security back on and still working fine. my router must have been set up for the ipod then when the ipod settings changed the router wouldn't allow it access.
  6. iBoss™

    iBoss™ Banned

    Joined:
    Aug 15, 2009
    Messages:
    1,057
    Likes Received:
    0
    Device:
    2G iPod touch
    I dont see what was wrong with your other thread...

Share This Page