iPod Touch 2G stuck on "Connect to iTunes" since iOS 4 update...

Discussion in 'iPod touch' started by ChaotiCc`, Jun 22, 2010.

  1. ChaotiCc`

    ChaotiCc` New Member

    Nov 29, 2007
    Likes Received:
    2G iPod touch
    Hello there,

    I update my iPod Touch 2G (not MC model) to iOS 4.0 yesterday. The fact is that whenever I update to 4.0 it just stays on the "Connect to iTunes" screen (without battery) and iTunes tells me it found an iPod in recovery mode. I had the exact same problem when I tried to update to iOS 4.0 GM like a week ago. However, when I restore to 3.1.3 (done that like three times now : one time for GM, and 2 times for public) I don't need my SHSH blobs at all to downgrade and when it's finished it boots fine in 3.1.3. I really don't know what to do... Anyone got a clue for this ?

    Thanks in advance,


    PS: In 3.1.3 it was jailbroken with Spirit


    Tried to re-downgrade to 3.1.3 it doesn't work anymore so I guess Apple finally disabled 3.1.3 activation...
    ------------------double post merged------------------
    Just tried to restore on another PC... Still got the same problem

    Please Register or Log in to view images

Share This Page