iPod Touch 1st Gen - error 6 when updating

Discussion in 'iPod touch Firmware 2.X' started by Xander1971, Sep 10, 2008.

  1. Xander1971

    Xander1971 New Member

    Joined:
    Sep 10, 2008
    Messages:
    1
    Likes Received:
    0
    really hoping one of you guys or gals can help here as this is pulling my hair out.

    - upgrading to 2.0 using iTunes 7.7 = error 6 after software extraction
    - upgrading to 2.1 using iTunes 8 = error 6 after software extraction

    Solution for un-bricking each time is to take it over to a PC that has not downloaded the update and restore from there using 1.1.5, iPod now working fine but of course its not on 2.1

    does anybody have a solution or is this upgrade just not working with 1st gen?

    I have tried every forum and googled all over the place with no joy.
  2. Tokenfreak

    Tokenfreak Member

    Joined:
    Sep 18, 2007
    Messages:
    317
    Likes Received:
    0
    Device:
    iPhone 4S (Black)
    make sure you are using f137 not f138 which is for ipod gen 2
  3. nbvikingsidiot001

    nbvikingsidiot001 Member

    Joined:
    Jan 28, 2008
    Messages:
    405
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    try putting the ipod into dfu mode then it will restore to the new firmware 2.1

    there are some great guides for dfu mode but im to tired and sick to tell you myself so if you go to forums type dfu in the search bar
  4. cainy

    cainy New Member

    Joined:
    Jan 12, 2008
    Messages:
    489
    Likes Received:
    0
    i think you will have to use the restore option not the update option
  5. nbvikingsidiot001

    nbvikingsidiot001 Member

    Joined:
    Jan 28, 2008
    Messages:
    405
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    yeah apple said there is no update option for 2.x.x from 1.x.x firmwares
  6. newdude

    newdude New Member

    Joined:
    Jul 4, 2008
    Messages:
    119
    Likes Received:
    0
    Device:
    iPod touch
    I think I got it! after hours of torment though. I'm also having error 6, my touch was in a coma for hours.

    I am not sure which step did it for me, but this is what I did.

    1. Downloaded firmware 2.1 from another link. (directly from apple)
    2. turned off my anti-virus which is nod32
    3. DFU mode
    4. Restored my previous firmware 2.0.2 (because as of that moment, my iPod is as good as a paper weight)
    5. after it restored, I shift clicked the update button, and pointed at my latest downloaded firmware.

    and to my surprise, the update finished!

    btw a fellow member gave me the link to the firmware, Louis6321 thanks again man!

    if you want I could also pm the link to you
  7. josh_ipod_touch

    josh_ipod_touch New Member

    Joined:
    Sep 10, 2008
    Messages:
    2
    Likes Received:
    0
    I was getting this error w/ the 2.0.1 firmware. After many attempts and restored the firmware, I discovered a thread that mentioned older ipods w/ W4 ending in the serial number had a hardware compatibility w/ the firmware. I made an appointment w/ the Apple Store Genius bar, and in a few minutes they exchanged my old ipod w/ a new one. Easy as that. Great customer service!

Share This Page