iPod Touch 1G won't connect to wifi. No idea why!

Discussion in 'iPod touch' started by Fzang, Jun 27, 2009.

  1. Fzang

    Fzang New Member

    Joined:
    Oct 12, 2008
    Messages:
    35
    Likes Received:
    0
    Device:
    iPad
    My room in the house is as far as you'll get from the route and the signal hits every wall on its way, so the connection in my room can be pretty dodgy at times.

    My iPod used to be able to connect, though sometimes disconnecting. One day I had very bad connectivity and it popped off the wifi but never on again, and it still refuses to connect.

    The wifi is WPA secured with a password containing numbers and only one letter. I've entered the password multiple times, reading directly off the router config page, trying with and without caps, "forgetting" the network and re-adding it and rebooting my iPod. None of this works! I keep getting "unable to connect".

    All other devices in the house connects just fine to the network!

    I tried an unsecured network network with very low signal and it worked just fine with my iPod, but my home wifi is just a no go...

    What's wrong?

Share This Page