iPod Touch 1G Recovery HELP

Discussion in 'iPod touch' started by LilNguyen7, May 6, 2009.

  1. LilNguyen7

    LilNguyen7 New Member

    Joined:
    May 5, 2009
    Messages:
    4
    Likes Received:
    0
    I have an iPod Touch 1G 2.2.1 in recovery mode after trying to update my Facebook app last night. The iPod crashed I believe and now is in recovery mode (it shows iTunes with an arrow from the USB cord). I've looked for guides or helps on this subject but cannot find anything that is according to firmware 2.2.1. Can anyone help me on this? I don't want to restore my iPod, this will be a last resort.

    Note: The picture shows an iTunes symbol with the USB end pointing to it, not the pin connector as most videos show.
    ------------------double post merged------------------
    I tried RedTool as well, and when I go to Boot > Boot my iPod from Recovery Mode, it just restarts my iPod TWICE and shows the same iTunes symbol and USB.
  2. interestingkid

    interestingkid Member

    Joined:
    Dec 6, 2007
    Messages:
    526
    Likes Received:
    3
    Device:
    iPhone 4 (Black)
    you have to restore, you just can't get out of recovery mode once you are in
    have you tried restarting? if that didn't work, then you're done lol
    you'll have to restore
    redtool's for only ipod touch 2g

Share This Page