iPod stuck at itunes logo with battery

Discussion in 'iPod touch' started by Shroomzor, Sep 21, 2010.

  1. Shroomzor

    Shroomzor Member

    Joined:
    Sep 28, 2008
    Messages:
    199
    Likes Received:
    0
    Device:
    iPhone 4 (Black)
    Ok recently my iPod touch wasn't being recognized in iTunes but it was able to charge.
    So I tried to restore and update my ipod touch to 4.1.
    In iTunes it said it restored successfully, then when my iPod is suppose to turn on, it goes to the iTunes and cable logo but it also displays the battery bar in the top right corner. So it's like the ipod turns on, but instead of a homescreen, I get an iTunes logo and battery bar.

    I tried recovery mode and I tried dfu mode. Don't know if I am doing anything wrong but I get the same results.

    EDIT: I tried to do it again and it worked, a mod can close this. I must not have been doing something right.
  2. Unregistered

    Unregistered Guest

    My ipod is stuck at recovery mode ( well its looks like it but it isnt)

    can u tell me how u did it plz i have the same problem

    Please Register or Log in to view images

  3. Unregistered

    Unregistered Guest

    help!

    i'm having the same problem too even though it tried to restore it many times.
    any help would be much appreciated.
  4. geniouslin

    geniouslin New Member

    Joined:
    Oct 5, 2010
    Messages:
    228
    Likes Received:
    1
    you are in the recovery mode. you have to restore to get out

Share This Page