iPod lost all music and videos, iTunes won't recognize

Discussion in 'iPod touch' started by Rusty, Mar 31, 2008.

  1. Rusty

    Rusty New Member

    Joined:
    Dec 1, 2007
    Messages:
    78
    Likes Received:
    1
    Hmm, I've really done it this time :S...

    So I installed AlliPodHax's "Create iPod app" application from his source in installer, and now all my music and videos are gone. I tried uninstalling the app, went into Music but it still didn't show. I went into iTunes and it says that it doesn't recognise it and I need to restore.

    I'll restore if I have to, or can some genius here help me for +rep and lots of love?
  2. 13yearoldbaldnerd

    13yearoldbaldnerd New Member

    Joined:
    Mar 24, 2008
    Messages:
    76
    Likes Received:
    0
    Try resetting your settings and deleting all content in Settings
  3. marko

    marko New Member

    Joined:
    Jan 10, 2008
    Messages:
    1,198
    Likes Received:
    13
    Device:
    iPhone 3GS (Black)
    not sure if this is the same problem but after installing some app, my ipod told me there was no music and videos and when i plugged in to itunes it said could not be recognized and needed to be restored. is that what youre getting?

    if it is, what worked for me was to SSH into the ipod and delete the iTunes_Control folder (i think its in/privae/var/root/library but not sure)

    anyway if you delete that then plug it back into iTunes it will recognise it and ask if you want to set it up as new or backup. if you choose backup it will keep all your apps and everything so you wont need to restore. but you will need to sync all your music and videos again.
  4. scottheonly

    scottheonly New Member

    Joined:
    Mar 27, 2008
    Messages:
    1
    Likes Received:
    0
    I have the same problem

    Please Register or Log in to view images

    . ughhh
  5. RetepNamenots

    RetepNamenots New Member

    Joined:
    Oct 17, 2007
    Messages:
    34
    Likes Received:
    0
    Device:
    2G iPod touch
    That SSH fix worked fantastic for me, thanks!

    FYI, the folder is in /private/var/root/Media/Media

    Now syncing all my music again, at least I didn't have to restore!

    Thanks.
  6. Ewizion

    Ewizion New Member

    Joined:
    Mar 13, 2008
    Messages:
    1
    Likes Received:
    0
    Works for me too! Thank you so much!

    Please Register or Log in to view images

    Please Register or Log in to view images

    Please Register or Log in to view images

  7. marko

    marko New Member

    Joined:
    Jan 10, 2008
    Messages:
    1,198
    Likes Received:
    13
    Device:
    iPhone 3GS (Black)
    glad it worked. i picked it up from another thread on here somewhere, so its not my fix. but it saved me the hassle of restoring and now you guys. so if anyone else asks, pay it forward. thats what help forums are all about

    edit:wonder if it actually worked for rusty? let us know dude

Share This Page