iPod Fifth Generation U2 DEAD??

Discussion in 'iPod classic, nano, etc.' started by PriteSprite, Jan 13, 2010.

  1. PriteSprite

    PriteSprite Member

    Joined:
    Feb 15, 2009
    Messages:
    704
    Likes Received:
    12
    Device:
    4G iPod touch
    Hey guys.

    Well basically, I bought an iPod U2 special edition fifth generation on 2006. One week ago, the iPod started making strange noises when you tried to turn it on, and after being in the Apple logo screen for about 10 seconds, a DEAD iPod image appears telling me to go to apple.com/support/ipod. Does this mean it is really dead? I tried restoring it and all. Seems to me the hard drive gave in, right?

    Thanks for your help.
  2. BigBossMan

    BigBossMan Member

    Joined:
    Sep 21, 2009
    Messages:
    713
    Likes Received:
    0
    Device:
    4G iPod touch
    ya it most likely is dead.. it can be various problems my old ipod did that when the hard drive just died. it would cost just as much as a new ipod if you would to fixed it
  3. PriteSprite

    PriteSprite Member

    Joined:
    Feb 15, 2009
    Messages:
    704
    Likes Received:
    12
    Device:
    4G iPod touch
  4. Hamihamz

    Hamihamz Member

    Joined:
    Jun 22, 2012
    Messages:
    123
    Likes Received:
    1
    Device:
    iPod touch
  5. 42395_skyline

    42395_skyline Community Development Staff Member

    Joined:
    Feb 14, 2009
    Messages:
    10,912
    Likes Received:
    489
    Device:
    iPhone 6
    Mine's dead too, never tried to fix it though.
  6. Hamihamz

    Hamihamz Member

    Joined:
    Jun 22, 2012
    Messages:
    123
    Likes Received:
    1
    Device:
    iPod touch

Share This Page