iPod failing to connect after reboot?

Discussion in 'iPod touch' started by B_Fin23, Mar 14, 2009.

  1. B_Fin23

    B_Fin23 New Member

    Mar 14, 2009
    Likes Received:
    I have a 2nd generation, 16gb iPod Touch, and I've been having some problems connecting to the internet from my home network lately. As far as I can tell, my network is a secure network. When I went to the Wi-Fi Connection in My Settings before this whole thing happened, my iPod was able to search for the network and would actually find it, but never connect to it on its own. For some reason, the only way I could get it to connect to the internet was to click on "Other..." underneath the networks and manually search for the same connection myself. I could click on this one, and my connection would work. I was on the internet one day (via my iPod) when suddenly, the window completely froze. After I waited for a good few minutes or so for it to come back, I decided to reset my iPod and try again. The problem is that ever since I've restarted it like that, my iPod no longer connects to the internet at all. I try doing the same method that I used to (going through "Other..." and searching) but every time I type in the name of the network, the Wi-Fi Networks window completely closes, and doesn't connect at all. It connects to other networks, though...if I take it to school, it easily connects to the school's internet connection with no problem at all. Does anyone know what's wrong, or how to fix this?

Share This Page