iPod done for?

Discussion in 'iPod touch' started by Ry-on40, Sep 21, 2009.

  1. Ry-on40

    Ry-on40 New Member

    Feb 1, 2009
    Likes Received:
    3G iPod touch
    About a week ago I was watching a video on my iPod and didnt realize it was nearly dead until it died. Its jailbroken with the tethered version of red snow, my iPod hadnt died or froze since I jailbroke it so I was fine with that version. Well now When I plug it into the computer itunes doesnt come up, I run all the boot up things through the command prompt and it boots up but has the little itunes logo with the usb plug on the screen.

    I held down the power button until the screen went black then tried putting it into DFU mode, my computer made a noise like it always does when it goes in yet the screen does the same thing. I really dont want to restore the original settings so does anyone know what is going on or what I should be doing?


    Also if it makes any difference I had to download iRecovery, firmware 2.1.1, and firmware 2.2.1 again since I deleted it forever ago.
  2. Screamworks

    Screamworks Member

    Jan 2, 2009
    Likes Received:
    4G iPod touch
    dude?> why thethered redsn0w?
    Go for untethered.
    Use redsn0w 0.3 for 2.2.1
    Use redsn0w 0.8 for 3.0

    (btw, just switched to 3.0, slightly buggy, but with all the added features, + apps that are exclusive (in Cydia [or in my case, Rock App], and the App Store], its wins hands down.)

Share This Page