iPod apps crashing + other things wrong...!

Discussion in 'iPod touch' started by Sepulcher, Oct 14, 2010.

  1. Sepulcher

    Sepulcher Member

    Joined:
    Sep 29, 2010
    Messages:
    171
    Likes Received:
    0
    Device:
    4G iPod touch
    I have a iPod Touch 2gen 8GB. I have 4.1 on it too, and have had 4.1 since it came out.

    About 20 minutes ago, I installed an app (Talking Billy Bob or something), and when I synced and tried to see how the app was, the logo of the makers of the app appeared, and went. I tried all the other apps I have, and they crashed too.

    To top all that off, my music has mysteriously disappeared, and it leaves a blank screen when I tap the music tab on the bottom.

    I'm restoring at the moment, but It's taking ages because it says it's downloading a iPod software update...it's taking about 30 mins, and currently on 18 mins left.

    What do you guys think is wrong? and if the same problem still comes back after restore, what should I do...?

    Thanks.
  2. Psoul

    Psoul Member

    Joined:
    Apr 7, 2010
    Messages:
    725
    Likes Received:
    3
    Device:
    iPhone 4S (Black)
    Go to APPLE!!
  3. iBricked

    iBricked Well-Known Member

    Joined:
    Apr 16, 2010
    Messages:
    5,874
    Likes Received:
    39
    Device:
    iPhone 5S
    A restore will do fine. Remember to delete Billy bob and restore from fresh. I sense it may be causing sandbox crash or sumthing
  4. Sepulcher

    Sepulcher Member

    Joined:
    Sep 29, 2010
    Messages:
    171
    Likes Received:
    0
    Device:
    4G iPod touch
    I am trying to restore, but whenever I do, it does some update and finishes and comes up with an error message saying the 'Connection timed out'.
    My iPod didn't turn off once in the session, and I made sure of it.

    Any help?
  5. lolmao

    lolmao Active Member

    Joined:
    Aug 17, 2010
    Messages:
    1,786
    Likes Received:
    1
    Device:
    4G iPod touch
    maybe it was a virus?
  6. Sepulcher

    Sepulcher Member

    Joined:
    Sep 29, 2010
    Messages:
    171
    Likes Received:
    0
    Device:
    4G iPod touch
    Solved!

    Nope. I solved it.

    I went into my iPod Touch's settings > General > and reset all settings as I couldn't do it by my PC. it took about 5 minutes, but it worked. Good as new!

    Please Register or Log in to view images

Share This Page