iPod 2.1 FW is out now???

Discussion in 'iPod touch Firmware 2.X' started by Abcmsaj, Sep 9, 2008.

  1. Abcmsaj

    Abcmsaj Retired Moderator

    Joined:
    Jan 26, 2008
    Messages:
    5,501
    Likes Received:
    122
    Device:
    iPhone 6 Plus
  2. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    Nope. Friday
  3. pinho2005

    pinho2005 New Member

    Joined:
    Apr 19, 2008
    Messages:
    16
    Likes Received:
    0
    Device:
    iPhone 3G (White)
  4. dohboy14

    dohboy14 New Member

    Joined:
    May 16, 2008
    Messages:
    60
    Likes Received:
    0
    Device:
    iPod touch
    yes it is out, but i'm not upgrading, i don't want to lose my jailbreak stuff
  5. Pilk

    Pilk New Member

    Joined:
    Dec 2, 2007
    Messages:
    41
    Likes Received:
    1
    im not touching anything until itunes tells me to update. it still says 2.0 on that page. im not shelling out £6 again.
  6. cainy

    cainy New Member

    Joined:
    Jan 12, 2008
    Messages:
    489
    Likes Received:
    0
    just about to download it now, its not going near my ipod though until i know it can be jailbroken...made that mistake with 2,0 and was stuck with dodgy firmware for about a month and i had no themes :lol:
  7. Tom_fn

    Tom_fn New Member

    Joined:
    Aug 21, 2008
    Messages:
    226
    Likes Received:
    0
    is out!???
  8. jpga13

    jpga13 Banned

    Joined:
    Dec 4, 2007
    Messages:
    11,591
    Likes Received:
    435
    Device:
    iPad 3
    I ran iTunes 8 and it came up but won't download.
  9. ihellago

    ihellago New Member

    Joined:
    Mar 12, 2008
    Messages:
    254
    Likes Received:
    0
    lol still when a jb 2.1 is out. and when you upgrade, you're still gonna lose all the jb stuff.
  10. milfette

    milfette New Member

    Joined:
    Apr 15, 2008
    Messages:
    31
    Likes Received:
    0
    isnt it free if you have 2.0? you only have to pay if your on 1.x

    im thinking about it...

Share This Page