IphpPod

Discussion in 'iOS Jailbreak & Cydia' started by Andrewistheshit, Apr 19, 2008.

?

Has this happened to you

  1. yes

    3 vote(s)
    30.0%
  2. no

    4 vote(s)
    40.0%
  3. yes a safari error but it says 404-

    3 vote(s)
    30.0%
  1. Andrewistheshit

    Andrewistheshit New Member

    Joined:
    Mar 20, 2008
    Messages:
    23
    Likes Received:
    0
    Ok so i installed everything but when i click on iphppod i get sent to a sarfi page that says forbidden
    is there more you have to do then just downlode apache web server?
  2. fatsnake69

    fatsnake69 New Member

    Joined:
    Nov 4, 2007
    Messages:
    105
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    yes you have to have PHP enabled and there is a guide somewhere on this site. search "apache php"
  3. krysus

    krysus New Member

    Joined:
    Dec 26, 2007
    Messages:
    101
    Likes Received:
    0
    If you do everything in the right order, it should work fine:

    'Standard' sources:
    1. Install BSD subsystem
    2. Install Apache
    3. Install PHP

    My iphpPod source (iphppod.googlepages.com/repo.plist):
    4. Install Apache httpd.conf (sets up Apache / PHP configuration directives and restarts apache)
    5. Install iphpPod
  4. Andrewistheshit

    Andrewistheshit New Member

    Joined:
    Mar 20, 2008
    Messages:
    23
    Likes Received:
    0
    COnfig Apache

    ugg ok for the httpd.conf file i put it in like this

    <IfModule mod_alias.c>

    #
    # Note that if you include a trailing / on fakename then the server will
    # require it to be present in the URL. So "/icons" isn't aliased in this
    # example, only "/icons/". If the fakename is slash-terminated, then the
    # realname must also be slash terminated, and if the fakename omits the
    # trailing slash, the realname must also omit it.
    #
    Alias /icons/ "/usr/share/httpd/icons/"

    <Directory "/usr/share/httpd/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    # This Alias will project the on-line documentation tree under /manual/
    # even if you change the DocumentRoot. Comment it if you don't want to
    # provide access to the on-line documentation.
    #
    Alias /manual/ "/Library/WebServer/Documents/manual/"

    <Directory "/Library/WebServer/Documents/manual">
    Options Indexes FollowSymlinks MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>

    #
    # ScriptAlias: This controls which directories contain server scripts.
    # ScriptAliases are essentially the same as Aliases, except that
    # documents in the realname directory are treated as applications and
    # run by the server when requested rather than as documents sent to the client.
    # The same rules about trailing "/" apply to ScriptAlias directives as to
    # Alias.
    #
    ScriptAlias /cgi-bin/ "/Library/WebServer/CGI-Executables/"

    #
    # "/Library/WebServer/CGI-Executables" should be changed to whatever your ScriptAliased
    # CGI directory exists, if you have that configured.
    #
    <Directory "/Library/WebServer/CGI-Executables">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all
    </Directory>

    ScriptAlias /php /opt/iphone/bin
    AddType application/x-httpd-php .php
    Action application/x-httpd-php "/php/php-cgi"

    </IfModule>
    # End of aliases.
    ScriptAlias /php /opt/iphone/bin
    AddType application/x-httpd-php .php
    Action application/x-httpd-php "/php/php-cgi"
    #
    # Redirect allows you to tell clients about documents which used to exist in


    and it does not work i get error 404 and i did the index.php
    and i fixed the path that went easy but i dont think i did the first part right

    Please Register or Log in to view images

    Please Register or Log in to view images

Share This Page