iPhone SDK 3.0 Toolchain Anyone?

Discussion in 'iOS Development' started by LeonBlade, Jun 25, 2009.

  1. LeonBlade

    LeonBlade New Member

    Joined:
    Sep 18, 2008
    Messages:
    8
    Likes Received:
    0
    Device:
    2G iPod touch
    Hey guys,

    I was wondering when we can expect some love for the Windows and Linux users?

    I used the toolchain on Linux and Windows to develop for 2.0, but now that 3.0 is out a lot of the Cydia apps don't work right for me and I can't develop for 3.0 cause... yeah... no toolchain.

    So when can we expect to see this?
    And if I can just do it myself, how would I go about doing it...

    Thanks,
    LeonBlade
  2. meilon

    meilon New Member

    Joined:
    Dec 31, 2007
    Messages:
    9
    Likes Received:
    0
    Device:
    iPhone 3G (Black)
    I would like to see a guide or how to, too!
  3. gaoning87

    gaoning87 New Member

    Joined:
    Jun 20, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    you can use the latest toolchain build app for 3.0 OS

    just fix some bug and replace some API which the undocument API has been removed form the offical SDK

    compile,your app may run smoothly on iphone OS 3.0
  4. dudeinasuit

    dudeinasuit New Member

    Joined:
    Jun 27, 2009
    Messages:
    1
    Likes Received:
    0
    what are you talking about the latest toolchain build...
    cuz i cant seem to find it
  5. muhu

    muhu Member

    Joined:
    Feb 27, 2009
    Messages:
    86
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    I assume gaoning means use Toolchain 2.0 from Cydia. Then extract the API's from the 3.0 SDK/Filesystem DMG image. SSH them onto your device into /usr/include. Then include them in your Makefile.

    Though I have not tried it on 3.0
  6. gaoning87

    gaoning87 New Member

    Joined:
    Jun 20, 2009
    Messages:
    9
    Likes Received:
    0
    Device:
    2G iPod touch
    you are right.the latest toolchain bases on the sdk 2.x.
  7. LeonBlade

    LeonBlade New Member

    Joined:
    Sep 18, 2008
    Messages:
    8
    Likes Received:
    0
    Device:
    2G iPod touch
    I don't have a Mac so I can't develop for it without the toolchain...
    So there is no release for the 3.0 firmware yet then?

    Can I do that thing that muhu said will that work?

    It sucks because half the apps wont work at all >.<
    I want to experiment with push notification and the other 1,000 APIs lol.
  8. Cyanidepoison

    Cyanidepoison Active Member

    Joined:
    Jan 18, 2008
    Messages:
    1,076
    Likes Received:
    2
    There has never been a release for anything. Just follow Saurik's guide on his website, replacing the frameworks with those from the 3.0 SDK and the headers from the 3.0 SDK>
  9. jfb392

    jfb392 New Member

    Joined:
    Oct 20, 2007
    Messages:
    2,512
    Likes Received:
    21
    Device:
    iPod touch
    Unfortunately, you cannot install the GNU compiler on 3.0; there is a broken dependency (libgcc) that prevents it from installing.
  10. muhu

    muhu Member

    Joined:
    Feb 27, 2009
    Messages:
    86
    Likes Received:
    0
    Device:
    iPhone 4S (White)
    After installing libgcc from a .deb package I am able to install the Toolchain. But still the compiler doesn't work right.

    Don't even try this unless you know what your doing.

    I have a general understanding of these things and I still messed up my Device pretty bad. I don't know what did it specifically...but now everything in my Applications.pwn folder is gone. Cydia, Safari, Mail, MMP, Notes, etc, etc, and etc.

Share This Page