iphone os problem

Discussion in 'iPod touch' started by lilmikey, Oct 20, 2008.

  1. lilmikey

    lilmikey New Member

    Joined:
    Dec 2, 2007
    Messages:
    691
    Likes Received:
    1
    Device:
    iPhone 3GS (White)
    when i try to install a app on appstore it says

    this application requires iphone os 2.1
    you must update to iphone os 2.1 in order to download and use this application

    wat do i do
  2. Joe Rossignol

    Joe Rossignol Community Manager Staff Member

    Joined:
    Jan 9, 2008
    Messages:
    11,500
    Likes Received:
    1,268
    Device:
    iPhone 5 (Black)
    You have an earlier version of Firmware 2.0 (whether it be Firmware 2.0, 2.0.1 or 2.0.2).

    Follow these steps:

    1. Plug your iPod touch into your computer.
    2. Open up iTunes and it will detect your iPod and place it under the Devices tab on the left.
    3. Click on your iPod touch under this Device tab.
    4. There will be a button on the right hand side, somewhat in the middle, that says Update. Click on this button, and you'll confirm whether or not you want to update. This will update your iPod firmware to version 2.1.
    5. The firmware will begin downloading. You can check the progress under the Downloads tab on the left hand side under the Store tab.
    6. Once finished downloading, it will begin to install onto your iPod.
    7. You now have Firmware 2.1 installed on your iPod touch.

    You now have Firmware 2.1 installed on your iPod touch and can use those applications from the App Store that require Firmware 2.1.
  3. atomicmufin

    atomicmufin Banned

    Joined:
    Jun 5, 2008
    Messages:
    1,549
    Likes Received:
    1
    Device:
    iPhone 4 (Black)
    ur avatar ftw.
  4. ryanlusk

    ryanlusk Banned

    Joined:
    May 17, 2008
    Messages:
    2,706
    Likes Received:
    0
    r u on 2.1 ?
  5. lilmikey

    lilmikey New Member

    Joined:
    Dec 2, 2007
    Messages:
    691
    Likes Received:
    1
    Device:
    iPhone 3GS (White)


    ya but its jailbroken i dnt want to lose all my stuff
    im on 2.0.1
  6. Joe Rossignol

    Joe Rossignol Community Manager Staff Member

    Joined:
    Jan 9, 2008
    Messages:
    11,500
    Likes Received:
    1,268
    Device:
    iPhone 5 (Black)
    There's no way to upgrade to Firmware 2.1 without loosing your jailbreak.

Share This Page