Iphone Booting, get to Apple Logo, then turns off, file recovery question

Discussion in 'iPhone' started by tryer77, Jan 8, 2010.

  1. tryer77

    tryer77 New Member

    Joined:
    Jan 8, 2010
    Messages:
    1
    Likes Received:
    0
    Device:
    iPhone
    Hi guys,

    I have a 2g Iphone, JB with 3.0.

    Everything was working great untill I went into the Appstore, and tried to run an update for the Facebook App.

    My battery died halfway through the process.

    It wouldn't boot up again.

    I left it charging the whole night.

    Now, it will only boot to the Apple logo, stays there for about 10-15 seconds, and then turns off.

    I can switch it into Recovery Mode, and DFU Mode, and my PC (Running XPSP3) makes the USB connected sound when I do put it into those modes.

    Now, I know that normally, a simple restore would be in order.

    But theres one tiny problem...

    My first child was born 2 weeks ago, and the only fotos I have of this occasion are currently on my phone.


    ================
    ================

    My questions are:

    1 - Is it possible to copy these pics off my Iphone somehow, being just in RMode or DFUMode?

    2 - If not, if I make a restore, will my old files still be there? (I havent synched in a long time with itunes so the pics weren't backed up)

    ================
    ================


    I have tried to connect with IRecover, and this is the information that it gives me:



    C:\LibUSB>irecovery -s
    iRecovery - Recovery Utility
    by wEsTbAeR-- and Tom3q

    Got USB
    C:\LibUSB>irecovery -s
    iRecovery - Recovery Utility
    by wEsTbAeR-- and Tom3q

    Got USB


    =======================================
    ::
    :: iBoot for m68ap, Copyright 2009, Apple Inc.
    ::
    :: BUILD_TAG: iBoot-596.24
    ::
    :: BUILD_STYLE: RELEASE
    ::
    :: USB_SERIAL_NUMBER: CPID:8900 CPRV:20 CPFM:03 SCEP:05 BDID:00 ECID:000000E242024DF5 IBFL:01 SRNM:[837460RFWH9]
    ::
    =======================================

    [FTL:MSG] Apple NAND Driver (AND) RO
    [NAND] Device ID 0xa(CENSORED)
    [NAND] BANKS_TOTAL 4
    [NAND] BLOCKS_PER_BANK 8320
    [NAND] PAGES_PER_BANK 1064960
    [NAND] SECTORS_PER_PAGE 4
    [NAND] BYTES_PER_SPARE 64
    [FTL:MSG] FIL_Init [OK]
    [FTL:MSG] BUF_Init [OK]
    [FTL:MSG] FPart Init [OK]
    read old style signature 0x(CENSORED) (line:301)
    [FTL:MSG] VFL Register [OK]
    [FTL:MSG] VFL Init [OK]
    [FTL:MSG] VFL_Open [OK]
    [FTL:MSG] FTL Register [OK]
    [FTL:MSG] FTL_Open [OK]
    Boot Failure Count: 9 Panic Fail Count: 1
    Entering recovery mode, starting command prompt
    ] (Recovery) iPhone$


    and here is what happens when I type in "printenv":


    (Recovery) iPhone$ printenv


    build-style = "RELEASE"
    build-version = "iBoot-596.24"
    config_board = "m68ap"
    loadaddr = "0x9000000"
    boot-command = "fsboot"
    idle-off = "true"
    boot-device = "nand0"
    boot-partition = "0"
    boot-path = "/System/Library/Caches/com.apple.kernelcaches/kernelcache.s5l8900x"
    display-color-space = "RGB888"
    display-timing = "optC"
    P backlight-level = "46"
    P bootdelay = "0"
    P filesize = "33550336"
    P platform-uuid = <DATA>
    P obliteration = "Enabling auto boot"
    P autoboot = "true"
    image-version = "0x3"
    framebuffer = "0xfd00000"
    secure-boot = "0x1"
    (Recovery) iPhone$ printenv^C

    I have tried doing both these processes:

    setenv auto-boot true
    saveenv
    fsboot

    and

    setenv auto-boot true
    saveenv
    reboot

    but it doesnt seem to help.

    I know a lot of people say "I really need to get my data back!!!!"

    I don't really NEEEED to get my pics back, but I would LOVE to be able to save the pictures of my boy's first day on this planet.

    If I missed anything out, please let me know, and if you can help out I would be extremely grateful.

    Thanks


    Note: While in DFU or Recovery, the phone seems to reboot automatically after 10-15 mins. (These reboot happen randomly)
  2. DrewGzy

    DrewGzy Active Member

    Joined:
    Dec 11, 2007
    Messages:
    1,205
    Likes Received:
    10
    Will it stay on the Apple logo if it is plugged in? If so can you SSH into it?

    Try doing a backup of it through iTunes; if it makes a backup the pictures will be in the backup file.

Share This Page